Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Administration & Installation

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 12th January 2017, 20:44
mike_rodri mike_rodri is offline
Junior Member
 
Join Date: Feb 2009
Posts: 3
mike_rodri is on a distinguished road
Baan: baan IVc - DB: SQL - OS: Windows2000
BaanIVC SP12 portingset 6.1c.17 upgrade
Baan: Baan IVc4
DB: SQL Server 2008 R2
OS: Windows 2008
C/S: None/Unknown

I have been tasked to plan and implement a upgraded of a BaanIV server to a new server and upgraded SQL server.

The current server is BaanIVC SP12, with portingset 6.1c.17 Level 1 drivers on SQL 2008 R2. The plan is a new Windows Server 2016 and SQL 2016 with level 2 drivers. Also Baan Licensing to SLM licensing.

If I am reading the technical notes correctly, the upgraded to 8.7b.01 is fairly straight forward, directly from 6.1c.17. Infor has suggested that we upgrade 1 portingset at time and install all patches and make sure all requirements are taken care of before moving to the next portingset.


The next issue is the level 1 to level 2 driver upgrade. Has anyone done this going to a new server?

Should the upgrade be done on the current server, full export/import of data, or should we install the level 2 drivers on the new server, move Baan and then export all the baan (company 000 and production companies) from the level 1 server and then just import on the new level 2 server?

Thank you for any suggestions or experiences regarding this,

Mike
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2017, 01:03
mig28mx's Avatar
mig28mx mig28mx is offline
Guru
 
Join Date: Nov 2003
Location: Mexico
Posts: 427
mig28mx is on a distinguished road
Baan: IVc4 - DB: Oracle 9i, Oracle10g - OS: HP Unix 11, Intel RedHat ES
upgrade carefully.

Hi mike,
I recently upgraded my linux servers from rh4 to rh7.
My experiences have not been smooth as I wished.

First of all, I planed to install oracle 12, and it will be required rh7. That was not the problem. From the baan side, to run rh7 I need at least, ps 8.xx.
This is because with rh7 all is 64 bits native and also the oracle db is on 64 bits.

Since I don´t use SLM, also I needed to to that conversion (I was on ps 6.1c.10).

When I converted my test environment to SLM and then I can move to ps 6.1c.17), I experienced some drop user´s without explanation, and some cryptic messages.

I have invested around 2 months to get the test environment up and runing, but I´m afraid to said that it will not a succesful migration from 6.x to 8.x

I have finished to install rh6.5 and oracle 11 in order to install ps 6.1c.19 on the baan side to get all up and running. This is due to, in ps 6.x the baan binaries are 32 bits, and in oracle 11 you still have 32/64 client versions.

Hope this helps.
__________________
We talk Baan!
Reply With Quote
  #3  
Old 19th January 2017, 19:39
mike_rodri mike_rodri is offline
Junior Member
 
Join Date: Feb 2009
Posts: 3
mike_rodri is on a distinguished road
Baan: baan IVc - DB: SQL - OS: Windows2000
Quote:
Originally Posted by mig28mx View Post
Hi mike,
I recently upgraded my linux servers from rh4 to rh7.
My experiences have not been smooth as I wished.

First of all, I planed to install oracle 12, and it will be required rh7. That was not the problem. From the baan side, to run rh7 I need at least, ps 8.xx.
This is because with rh7 all is 64 bits native and also the oracle db is on 64 bits.

Since I don´t use SLM, also I needed to to that conversion (I was on ps 6.1c.10).

When I converted my test environment to SLM and then I can move to ps 6.1c.17), I experienced some drop user´s without explanation, and some cryptic messages.

I have invested around 2 months to get the test environment up and runing, but I´m afraid to said that it will not a succesful migration from 6.x to 8.x

I have finished to install rh6.5 and oracle 11 in order to install ps 6.1c.19 on the baan side to get all up and running. This is due to, in ps 6.x the baan binaries are 32 bits, and in oracle 11 you still have 32/64 client versions.

Hope this helps.
Thank you for the post about your experience with the upgrade. It helps and lets me know that this upgrade might not be as straight forward as it looked on paper. One of my last complicated upgrades, I got a "Good Luck" comment from support.
Reply With Quote
  #4  
Old 25th January 2017, 11:47
Han Brinkman's Avatar
Han Brinkman Han Brinkman is offline
Guru
 
Join Date: Aug 2001
Location: The Netherlands
Posts: 1,155
Han Brinkman has a spectacular aura aboutHan Brinkman has a spectacular aura about
Baan: All - DB: Oracle/ms-sql/db2 - OS: *nix/windows
It's do-able.

Just make sure that your old baan environment is able to use SLM.
On the new server install the rdbms software, install latest portingset. Install SLM, get the license key.
Than export all tables, import them on the new server.
Rename the new BSE, copy the old one over and merge them (not overwriting the portingset!)
Reply With Quote
  #5  
Old 26th January 2017, 17:45
mike_rodri mike_rodri is offline
Junior Member
 
Join Date: Feb 2009
Posts: 3
mike_rodri is on a distinguished road
Baan: baan IVc - DB: SQL - OS: Windows2000
Quote:
Originally Posted by Han Brinkman View Post
It's do-able.

Just make sure that your old baan environment is able to use SLM.
On the new server install the rdbms software, install latest portingset. Install SLM, get the license key.
Than export all tables, import them on the new server.
Rename the new BSE, copy the old one over and merge them (not overwriting the portingset!)
Han,
Thank you. That is what I have planned and hope to start soon. I will have to verify that the old environment can use SLM. At least I will have a couple of test servers to work on first.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade Oracle DB 10gR2 to 11gR2 on BaanIVc hpxt6200 Operating Systems & Databases 6 27th March 2015 12:26
after upgrade portingset to 8.4a.01,in bdbpost error -520 vaishali Tools Administration & Installation 11 25th December 2007 13:15
Porting set/ BW.exe upgrade ?/issue chadwickh Tools Administration & Installation 4 2nd October 2006 16:37
Portingset upgrade. windham Tools Administration & Installation 2 27th January 2003 18:33
Upgrade portingset AlexGuo Tools Administration & Installation 15 20th November 2002 23:00


All times are GMT +2. The time now is 10:00.


©2001-2017 - Baanboard.com - Baanforums.com