Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2012, 18:37
ipineda's Avatar
ipineda ipineda is offline
Member
 
Join Date: Aug 2008
Posts: 38
ipineda is on a distinguished road
Baan: BaaN V, LN - DB: Oracle - OS: Unix, Windows
Ping failed: Connection creation failed
Baan: ERP LN 6.1 FP7
C/S: None/Unknown

Hi friends,

I’m trying to develop in Infor ERP LN FP7 through Application Studio 8.7. I was connected to the development environment but the administrator installed solutions and apparently did some modifications to the system and now I can´t get connected. My problem is that I can´t configure the Development Connection Point.
In the window Window/Preferences in the option Infor ERP Connectivity Preferences I configure the connection point using and existing BWC file but when I try to ping I get the following error:

“Ping failed: Connection creation failed – createManagedConnection(External Activation) failed –Connect failed with host:serverlnfp7 and port:11600”

serverlnfp7 is the name of my server but I don´t kwon where the port number comes from.
Another change that was made in the system is that before we use rexec as protocol and now we use BaaNLogin, but I don´t know if that matters.
I would really appreciate your help,

Thanks.
Reply With Quote
  #2  
Old 12th January 2012, 13:57
JaapJD's Avatar
JaapJD JaapJD is offline
Guru
 
Join Date: Sep 2002
Location: Netherlands
Posts: 728
JaapJD will become famous soon enoughJaapJD will become famous soon enough
Baan: BaanIV, BaanERP, ERP LN 6.1 - DB: Oracle, SQL Server - OS: Unix, Windows
It seems that your admin changed something that no socket connections to the server are allowed. It may be handy to activated JCA logging (level INFO or DEBUG) and write it to a file (see Preferences Infor ERP LN Connection Preferences > Log configuration) and also the "trace backend" in the connection point. For the latter you will get logging on the server in $BSE/log.
Reply With Quote
  #3  
Old 12th January 2012, 17:22
ipineda's Avatar
ipineda ipineda is offline
Member
 
Join Date: Aug 2008
Posts: 38
ipineda is on a distinguished road
Baan: BaaN V, LN - DB: Oracle - OS: Unix, Windows
The log file gives the following information, with debug level:

Quote:
2012-01-12 10:47:39,604 INFO [JCAPlugin] start()
2012-01-12 10:47:39,604 DEBUG [ConnectionFactoryImpl] ConnectionFactoryImpl(ManagedConnectionFactory, ConnectionManager)
2012-01-12 10:47:39,635 DEBUG [ConnectionFactoryImpl] getConnection((ConnectionSpec)
2012-01-12 10:47:39,635 INFO [ConnectionPointsManager] Filename not found (connectionpoints.xml)
2012-01-12 10:47:39,635 INFO [ConnectionManagerImpl] allocateConnection()
2012-01-12 10:47:39,635 INFO [ConnectionManagerImpl] Allocate a new connection
2012-01-12 10:47:39,635 DEBUG [ManagedConnectionFactoryImpl] createManagedConnection((Subject),(ConnectionRequestInfo))
2012-01-12 10:47:39,635 INFO [ManagedConnectionFactoryImpl] External Activation detected, activation string = 'EA:ProjectServer'
2012-01-12 10:47:39,635 INFO [ExternalActivationImpl] Start server for activationType 'EA:ProjectServer', using OLE-Automation via BW (parseExecFunction)
2012-01-12 10:47:39,651 INFO [ExternalActivationImpl] Create OleClientSite for progID 'Baan.Application.NovatechLNFP7Local'
2012-01-12 10:47:42,349 INFO [ExternalActivationImpl] Create OleAutomation for programID 'Baan.Application.NovatechLNFP7Local'
2012-01-12 10:47:42,396 INFO [ExternalActivationImpl] Hostname from CPP: ''
2012-01-12 10:47:42,396 INFO [ExternalActivationImpl] Returned URI 'tcp://serverlnfp7:11600'
2012-01-12 10:47:42,396 INFO [ManagedConnectionFactoryImpl] Returned reference from External Activation = 'tcp://serverlnfp7:11600'
2012-01-12 10:47:42,396 DEBUG [SocketSessionLayer] Enter: connect()
2012-01-12 10:47:42,396 DEBUG [SocketSessionLayer] Enter: close()
2012-01-12 10:47:42,396 DEBUG [SocketSessionLayer] Leave: close()
2012-01-12 10:48:03,441 ERROR [ManagedConnectionFactoryImpl] createManagedConnection --> exception
com.infor.erpln.protocol.BaanConnectionException: Connect failed with host:serverlnfp7 and port: 11600
at com.infor.erpln.protocol.SocketSessionLayer.doConnect(Unknown Source)
at com.infor.erpln.protocol.SocketSessionLayer.connect(Unknown Source)
at com.infor.erpln.jca.ManagedConnectionFactoryImpl.createManagedConnection(Unknown Source)
at com.infor.erpln.jca.ConnectionManagerImpl.allocateConnection(Unknown Source)
at com.infor.erpln.jca.ConnectionFactoryImpl.getConnection(Unknown Source)
at com.infor.erpln.jca.connectivity.JCAPlugin.getConnection(JCAPlugin.java:355)
at com.infor.erpln.jca.connectivity.JCAPlugin.getBdeManager(JCAPlugin.java:367)
at com.infor.erpln.jca.connectivity.JCAPlugin.getBdeManager(JCAPlugin.java:215)
at com.infor.fourglstudio.connectivity.proxy.core.RequestMessage.initializeStaticConnection(RequestMessage.java:121)
at com.infor.fourglstudio.connectivity.proxy.ProjectServerConnection.<init>(ProjectServerConnection.java:24)
at com.infor.projectserver.ui.internal.ListProjectsHavingNoTask.<init>(ListProjectsHavingNoTask.java:28)
at com.infor.projectserver.ui.views.SwpContentProvider.listEmptyProjects(SwpContentProvider.java:85)
at com.infor.projectserver.ui.views.SwpContentProvider.initialize(SwpContentProvider.java:75)
at com.infor.projectserver.ui.views.ProjectServerView.createPartControl(ProjectServerView.java:115)
at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:367)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:226)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
at org.eclipse.ui.internal.WorkbenchPage$ActivationList.setActive(WorkbenchPage.java:4212)
at org.eclipse.ui.internal.WorkbenchPage$18.runWithException(WorkbenchPage.java:3271)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3885)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3506)
at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)
at org.eclipse.ui.internal.Workbench$28.runWithException(Workbench.java:1384)
at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3885)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3506)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2316)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Does it mean anything to you?

I also have looked in $BSE/log but I don't find anything useful.

When I create a different Connection Point for example ProjectServer I can select another activation type. If I select BaanLogin it works fine but if I change the activation type for the same Connection Point to BW it crashes. The strange thing is that the BWC file uses BaanLogin too. And the problem is that Develoment Connection Point nedds BW connection type.

About the sockets, do you know a way to test JCA sockets and find problems about that?

Thanks for help
Reply With Quote
Sponsored Links
  #4  
Old 13th January 2012, 08:33
JaapJD's Avatar
JaapJD JaapJD is offline
Guru
 
Join Date: Sep 2002
Location: Netherlands
Posts: 728
JaapJD will become famous soon enoughJaapJD will become famous soon enough
Baan: BaanIV, BaanERP, ERP LN 6.1 - DB: Oracle, SQL Server - OS: Unix, Windows
BW connects to port 7150 by default voor BaanLogin and 512 for rexec. The problem is not that BW cannot connect in your case. BW and a bshell are started during the ping, otherwise you would not have come so far. But then Application Studio tries to communicate with that bshell via port 11600 (for which the bshell started a listener), but AS cannot connect to that port. So, it seems that your admin configured something at firewall level that socket connections to those ports are not allowed.
Reply With Quote
  #5  
Old 13th January 2012, 16:22
ipineda's Avatar
ipineda ipineda is offline
Member
 
Join Date: Aug 2008
Posts: 38
ipineda is on a distinguished road
Baan: BaaN V, LN - DB: Oracle - OS: Unix, Windows
Problem Solved

JaapJD you are right, the problem was the firewall. When the admin change the used protocol from rexec to BaanLogin he gave access just for the login process (7150) port but when developing in Application Studio you need extra ports like 11600. It is important to mention that 11600 is not the only port used so what I did is create an input rule in the firewall to allowed the range 11000-12000 because I don´t know exactly the range of necessary ports.

Thank you so much.
Reply With Quote
  #6  
Old 13th January 2012, 16:24
JaapJD's Avatar
JaapJD JaapJD is offline
Guru
 
Join Date: Sep 2002
Location: Netherlands
Posts: 728
JaapJD will become famous soon enoughJaapJD will become famous soon enough
Baan: BaanIV, BaanERP, ERP LN 6.1 - DB: Oracle, SQL Server - OS: Unix, Windows
Application Studio starts at 11600 and increases the port number for other users.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp bilmaa Tools Development 12 13th October 2016 13:49
Getoverlapped result failed() - 1236 -Network connection was aborted by local system sankuu Tools Administration & Installation 3 25th March 2011 17:42
To move file over FTP Arjit Gupta Tools Administration & Installation 1 16th December 2010 14:45
Cannot create ERP template : Failed to open connection Elrodyn Open World, Portal & Decision Manager 0 4th March 2010 12:52
Help regarding tools session rahul.kolhe22 Tools Development 4 22nd January 2010 13:31


All times are GMT +2. The time now is 23:34.


©2001-2017 - Baanboard.com - Baanforums.com