Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 28th July 2011, 11:23
puneet.verma puneet.verma is offline
Junior Member
 
Join Date: Jul 2007
Posts: 14
puneet.verma is on a distinguished road
Baan: baan4 and LN6 - DB: oracle9i and MSSQL2000/05 - OS: Windows NT
emessage connector
Baan: ERP LN 6.1 FP2
C/S: Server

Hi,
I'm configuring emessage connector but I'm unsure of the Service Provider Parameters specifically the <Mail From> domain. I'd like to have some examples for this parameter.

Thanks
Reply With Quote
  #2  
Old 28th July 2011, 14:52
mark_h's Avatar
mark_h mark_h is offline
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 6,906
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
Search on emssage connectors. I know there are some posts with sample code. Not sure if that is what you are looking for. NPRao linked in the help documentation on the board.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #3  
Old 29th July 2011, 07:08
VishalMistry's Avatar
VishalMistry VishalMistry is offline
Guru
 
Join Date: Dec 2004
Location: India, Gujarat
Posts: 568
VishalMistry has a little shameless behaviour in the past
Baan: Baan IV, ERPLn - DB: SQL Server 2000 / 2008 - OS: Windows Server 2003 / 2008
Red face

Quote:
Originally Posted by puneet.verma View Post
Hi,
I'm configuring emessage connector but I'm unsure of the Service Provider Parameters specifically the <Mail From> domain. I'd like to have some examples for this parameter.

Thanks
Hi,

We are using eMessage connector. I am attaching screen shots. Hope it helps.

Vishal
Attached Files
File Type: zip eMsgConnector Settings.zip (102.6 KB, 147 views)
Reply With Quote
  #4  
Old 30th July 2011, 13:27
puneet.verma puneet.verma is offline
Junior Member
 
Join Date: Jul 2007
Posts: 14
puneet.verma is on a distinguished road
Baan: baan4 and LN6 - DB: oracle9i and MSSQL2000/05 - OS: Windows NT
Exclamation Thanks...a few questions !

Hi Vishal, firstly thanks for your documented response, I have this setup already in place but still I'm unable to send mails. I have a few questions which might help me to corretly set this up.
1. When the mail is sent through emessage connector, what's the sender's name, subject and content of the email.
2. What mailbox does emessage connector use for sending the email ?
3. How can I configure my own sender's name (email id), subject and content ?


Regards,
Puneet
Reply With Quote
Sponsored Links
  #5  
Old 1st August 2011, 06:16
VishalMistry's Avatar
VishalMistry VishalMistry is offline
Guru
 
Join Date: Dec 2004
Location: India, Gujarat
Posts: 568
VishalMistry has a little shameless behaviour in the past
Baan: Baan IV, ERPLn - DB: SQL Server 2000 / 2008 - OS: Windows Server 2003 / 2008
Red face

Quote:
Originally Posted by puneet.verma View Post
Hi Vishal, firstly thanks for your documented response, I have this setup already in place but still I'm unable to send mails. I have a few questions which might help me to corretly set this up.
1. When the mail is sent through emessage connector, what's the sender's name, subject and content of the email.
2. What mailbox does emessage connector use for sending the email ?
3. How can I configure my own sender's name (email id), subject and content ?


Regards,
Puneet
Hello Mr.Punit,

*There are two ways to send emails using eMsg connector. One using SMTP in non interactive mode and other through Outlook adapter. When you use SMTP connector, you can specify in your code, what should be the from id and "from name" and it does not use any local mail profile.
*If you use Outlook adapter in your code, your local mail profile will be used and the system will automatically use the default mail account of outlook as Sender. Also mails you send using outlook will appear in Sent Items folder of your local mail profile.

I am attaching script of my session. In my program script, I have used SMTP connector in non-interactive mode. Hope it helps.

Vishal
Attached Files
File Type: bc script.bc (16.5 KB, 104 views)
Reply With Quote
  #6  
Old 1st August 2011, 12:47
puneet.verma puneet.verma is offline
Junior Member
 
Join Date: Jul 2007
Posts: 14
puneet.verma is on a distinguished road
Baan: baan4 and LN6 - DB: oracle9i and MSSQL2000/05 - OS: Windows NT
Question

Hi Vishal,

I've configured two devices for outlook and smtp. However while using the outlook device I get a mail from system administrator
"Your message did not reach some or all of the intended recipients.
None of your e-mail accounts could send to this recipient."
I have also defined both the sender and recipient in the address book session.
For SMTP I created a scriprt from the one provided by you. While debugging I did not get any errors but the mail was not sent. Is there any additional configuration required on the ERP server for this ? Do I need to setup a new mailbox ? Infor told me to use the ERP server name as the <mail from> domain in the Provider parameters, but you have defined your company domain and it's working for you !
Reply With Quote
  #7  
Old 2nd August 2011, 05:54
VishalMistry's Avatar
VishalMistry VishalMistry is offline
Guru
 
Join Date: Dec 2004
Location: India, Gujarat
Posts: 568
VishalMistry has a little shameless behaviour in the past
Baan: Baan IV, ERPLn - DB: SQL Server 2000 / 2008 - OS: Windows Server 2003 / 2008
Red face

Quote:
Originally Posted by puneet.verma View Post
Hi Vishal,

I've configured two devices for outlook and smtp. However while using the outlook device I get a mail from system administrator
"Your message did not reach some or all of the intended recipients.
None of your e-mail accounts could send to this recipient."
I have also defined both the sender and recipient in the address book session.
For SMTP I created a scriprt from the one provided by you. While debugging I did not get any errors but the mail was not sent. Is there any additional configuration required on the ERP server for this ? Do I need to setup a new mailbox ? Infor told me to use the ERP server name as the <mail from> domain in the Provider parameters, but you have defined your company domain and it's working for you !
Hi Mr.Punit,

As you would have seen in my code, I am not fetching recipient from address book defined in ERPLn, but I use the e-mail id defined in addresses session, and this address in-turn is linked to business partner.

Also, we have a proxy mail server, which does not require any authentication and I use SMTP service of this server. There is no extra configuration done apart from this.

Vishal
Reply With Quote
  #8  
Old 3rd August 2011, 05:49
puneet.verma puneet.verma is offline
Junior Member
 
Join Date: Jul 2007
Posts: 14
puneet.verma is on a distinguished road
Baan: baan4 and LN6 - DB: oracle9i and MSSQL2000/05 - OS: Windows NT
Thumbs up Setup OK

Hi Vishal,

Thanks for all your inputs. Infor has validated the application setup for emessage connector, there is some issue with the mail server blocking these mails.

I'm attaching the screenhots of the setup for future reference.
Attached Files
File Type: doc emessage connector setup.doc (424.5 KB, 44 views)
Reply With Quote
  #9  
Old 4th August 2011, 07:41
VishalMistry's Avatar
VishalMistry VishalMistry is offline
Guru
 
Join Date: Dec 2004
Location: India, Gujarat
Posts: 568
VishalMistry has a little shameless behaviour in the past
Baan: Baan IV, ERPLn - DB: SQL Server 2000 / 2008 - OS: Windows Server 2003 / 2008
Red face

Quote:
Originally Posted by puneet.verma View Post
Hi Vishal,

Thanks for all your inputs. Infor has validated the application setup for emessage connector, there is some issue with the mail server blocking these mails.

I'm attaching the screenhots of the setup for future reference.
Hello Punit,

One possible cause (which I faced initially in our setup too) might be your mail server is treating the e-mails generated through eMsg connector as SPAMs. There must be some feature in you mail system where you can specify IP address of the ERPLn application server which is generating mails, which in-turn will allow messages from particular IP address and will not consider as SPAMs.

Regards,
Vishal
Reply With Quote
  #10  
Old 16th January 2017, 11:12
MilindV's Avatar
MilindV MilindV is offline
Senior Member
 
Join Date: Feb 2008
Location: Hyderabad, India
Posts: 107
MilindV is on a distinguished road
Baan: LN, BaaN-IVc4, BaaN-Vc - DB: SQL Server - OS: Windows, Unix
Device for sending email

Hi All,

Could you please help me with issue while setting up Device for sending mail in LN 10.4?

Refer attached file for device set up and CMF set up.
With this set up I get error message in my mail box Refer attached file 'Capture'.

It will be of great help, if you could provide your inputs.

Thank you very much in advance.

Regards,
Milind
Attached Images
File Type: jpg Capture.JPG (42.8 KB, 8 views)
Attached Files
File Type: doc Device Set Up _ And CMF Set Up.doc (192.0 KB, 10 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CMF / eMessage Connector ulrich.fuchs Tools Administration & Installation 5 13th April 2015 19:54
eMessage Connector - name and extension of attachment changes VishalMistry Tools Development 14 12th March 2014 02:37
BaaN Open World and IVc4 Muetze Open World, Portal & Decision Manager 8 2nd February 2012 10:38
eMessage Connector examples Marioth Tools Development 8 22nd November 2010 09:57
eMessage Connector function pparamo Tools Development 3 5th September 2003 18:40


All times are GMT +2. The time now is 09:48.


©2001-2017 - Baanboard.com - Baanforums.com