Baanboard.com

Go Back   Baanboard.com > Forum > Baan SIGs > Performance & Tuning

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
37%
Installation Wizard into new VRC
39%
Manual into existing VRC
3%
Manual into new VRC
21%
Total votes: 38

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 16th February 2007, 13:43
akashag21's Avatar
akashag21 akashag21 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 18
akashag21 is on a distinguished road
Baan: Baan4 - DB: informix - OS: Windows NT
Standard session running slow

Hi,
We are working on Baan4.. we have an standard session of distribution which is running very slow .....

Any suggestion ????
Reply With Quote
  #2  
Old 16th February 2007, 14:41
mark_h's Avatar
mark_h mark_h is online now
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 6,933
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
More information is needed. Has it always run slow or did it just start? In what way is it slow - moving from one record to the next(or previous)? Maybe the session name would help someone? In Oracle(sometimes) this is fixed by running statistics - have you do the informix equivalent?
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #3  
Old 16th February 2007, 15:50
akashag21's Avatar
akashag21 akashag21 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 18
akashag21 is on a distinguished road
Baan: Baan4 - DB: informix - OS: Windows NT
More info

Well as soon as the session is opened it does not get data fetch from the table or so the cursor hangs on for 8mins .
This problem is occurring for last one month.
The databse used being in informix.Update statistics is being done tooo..
Reply With Quote
  #4  
Old 16th February 2007, 17:06
mark_h's Avatar
mark_h mark_h is online now
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 6,933
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
Which session? I have seen a couple of sessions mentioned on this board with problems and a couple of work arounds. I know on my system I just had to change the start option on one session that became slow. You might want to do a search on your session name and see what you find.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #5  
Old 17th February 2007, 06:56
akashag21's Avatar
akashag21 akashag21 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 18
akashag21 is on a distinguished road
Baan: Baan4 - DB: informix - OS: Windows NT
The session is tisfc0102m000

Hi i have seesn other posts for the same session but there conditinos are different.

In This session(the lower part) in it self gets opened so slowly..
Reply With Quote
  #6  
Old 19th February 2007, 15:55
mark_h's Avatar
mark_h mark_h is online now
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 6,933
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
I would see if your DBA could maybe trace the performance. I would concentrate around tisfc010. I would also contact SSA support to see if they could help. All I can think of for know.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #7  
Old 23rd February 2007, 15:33
Dikkie Dik's Avatar
Dikkie Dik Dikkie Dik is offline
Guru
 
Join Date: Sep 2002
Location: Netherlands
Posts: 585
Dikkie Dik is on a distinguished road
Baan: Triton 3.0 and higher - DB: All - OS: All
What changed?

What was changed during the last month? Don't tell me that nothing changed, else this would not happen. Portingset? Informix upgrade? solution?

Kind regards,
Dick
__________________
BTW: this post has been made on my personal view. My employer might not share my point of view.
Reply With Quote
  #8  
Old 24th February 2007, 09:16
sukesh75's Avatar
sukesh75 sukesh75 is offline
Guru
 
Join Date: Dec 2002
Posts: 1,031
sukesh75 is on a distinguished road
Baan: Baan 4c - DB: SQL Server 2000 - OS: Windows 2003
Question

Are you getting this when you are logged on as baan(super user) or as a normal user? Any new user authorizations on sessions or tables set in the last one month?

sk
Reply With Quote
  #9  
Old 24th February 2007, 16:20
akashag21's Avatar
akashag21 akashag21 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 18
akashag21 is on a distinguished road
Baan: Baan4 - DB: informix - OS: Windows NT
Ya. there were few activites.. one is level 1to level 2 to migration(dec mid) and porting set upgradation(in dec starting)....Only this sesion is having problem..
Reply With Quote
  #10  
Old 24th February 2007, 17:37
EdwinvdBorg EdwinvdBorg is offline
Guru
 
Join Date: Aug 2001
Location: Netherlands
Posts: 514
EdwinvdBorg is on a distinguished road
Baan: 2.2, 3.1, b40, b50, b51, ERP LN FP3, ERP LN FP7, ERP LN 10.2.1 - DB: ALL - OS: ALL
I do not believe this problem is due to a generic cause. It simply has to do with one session and should be looked at from an application perspective rather than a technical (tools and hardware) perspective.

I can think of two possible causes:

- Since you are now on a level 2 database driver you have to make sure the BAAN software object for tisfc0102 is supporting this level 2 situation. Your best bet may be to install the latest solution for tisfc0102m000. In the past performance enhancements were made for this session and the level of the database driver may have an impact
- I remember there is a problem with the performance in this session when a BAAN customer is using lot-controlled items in Manufacturing.
By running session tisfc0102m000 in profile mode you should be able to find the part of the program that is causing this problem. The profile action make take a day or two but it will be worth the effort.

Good luck!
__________________
Regards,

Edwin
Moderator BaanBoard
E-Mail: edwin@baanboard.com
Reply With Quote
  #11  
Old 9th March 2007, 14:58
Dikkie Dik's Avatar
Dikkie Dik Dikkie Dik is offline
Guru
 
Join Date: Sep 2002
Location: Netherlands
Posts: 585
Dikkie Dik is on a distinguished road
Baan: Triton 3.0 and higher - DB: All - OS: All
I agree with Edwin. If after all the performance is stiil bad, create a Call Graph Profile (see Chapter 2 of this document, and log an issue at Baan Support with this output.

Hope this helps,
Dick

BTW: I understood that the latest Informix version (IDS 10.00.xC6) is performing better than the previous versions.
__________________
BTW: this post has been made on my personal view. My employer might not share my point of view.
Reply With Quote
Sponsored Links
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to know who is running what Baan session in UNIX jaymukh Tools Administration & Installation 2 9th June 2005 21:01
Running session without user intervention mprakash Tools Development 1 30th August 2004 07:53
Pass values from standard session to a customized session !!! learner Tools Development 3 16th May 2003 22:07
Baan errors when running session via OLE francishsu Tools Development 1 30th November 2001 01:32


All times are GMT +2. The time now is 00:28.


©2001-2017 - Baanboard.com - Baanforums.com