Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Operating Systems & Databases

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
37%
Installation Wizard into new VRC
39%
Manual into existing VRC
3%
Manual into new VRC
21%
Total votes: 38

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 6th October 2004, 10:47
vineetu1's Avatar
vineetu1 vineetu1 is offline
Senior Member
 
Join Date: Jun 2002
Location: INDIA
Posts: 130
vineetu1 is on a distinguished road
Baan: BAAN C4 IN5 - DB: INFORMIX - OS: WINDOWS 2000
Problem with informix database

Our Informix database in the development server is not working since past two days.

After starting the services 1) Informix Server Discovery Process for SNMP 2) Informix Dynamic Server Message Service when I start Informix IDS 2000 - ol_testbaan it stops immediatey.

It shows the following error
1) In windows event viewer :
Code:
----------------------------
ol_testbaan : listener-thread: err = -931: oserr = 0: errstr = turbo: Cannot locate turbo service/tcp service in /etc/services.
2) In informix log :
Code:
---------------------
13:03:53  listener-thread: err = -931: oserr = 0: errstr = turbo: Cannot locate turbo service/tcp service in /etc/services.

13:03:53  Attempting to bring listener thread down.

13:03:53  Server stopped.

13:03:53  Informix Dynamic Server 2000 Stopped.
I have referred the Informix Errors file where the following has been given for -931 error.
Quote:
********************************************************************
-931

Cannot locate servicename service/tcp service in /etc/services.

The service servicename is not listed in the network configuration file /etc/services (UNIX) or (DOS). Check the $INFORMIXDIR/etc/sqlhosts file, and check that the service name for the desired server is correct. If so, contact your network administrator to find out why the service is not known. If you are using INFORMIX-OnLine for NetWare, check the file on the client for the required entries.

*****************************************************************
I did not find the sqlhosts file in the informix directory.

I have also checked the entry in winnt/system32/drivers/etc/services file
Code:
"turbo		     1526/tcp		   		    #ol_testbaan"
Kindly let me know how to solve this.
__________________
Vineet

Last edited by patvdv : 6th October 2004 at 17:30. Reason: Added vB tags
Reply With Quote
  #2  
Old 6th October 2004, 16:52
triton45 triton45 is offline
Member
 
Join Date: Jul 2002
Posts: 30
triton45 is on a distinguished road
Baan: IVc4 - DB: Informix 9.4 - OS: HP-UX 11.11
You need to verify the service name with the entry in the sqlhosts file. Being a unix guy myself, I assume the $informixdir would be something like c:\informix on windows. You must have a sqlhosts file for the server to work.

sqlhosts example
ol_testbaan my_machine_name turbo

services example
turbo 1526/tcp #ol_testbaan

You really need to think about upgrading. IDS 2000 reached end of support on 30-Jun-2004.

Andy
Reply With Quote
Sponsored Links
  #3  
Old 11th October 2004, 07:18
vineetu1's Avatar
vineetu1 vineetu1 is offline
Senior Member
 
Join Date: Jun 2002
Location: INDIA
Posts: 130
vineetu1 is on a distinguished road
Baan: BAAN C4 IN5 - DB: INFORMIX - OS: WINDOWS 2000
I have already checked all that.

In Windows 2000 there is no SQLHOST FILE.

If I am not wrong in Win 2k there entry is in Registery
Code:
[HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SQLHOSTS]
[HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SQLHOSTS\ol_t estbaan]
"HOST"="VINEET"
"OPTIONS"=""
"PROTOCOL"="olsoctcp"
"SERVICE"="turbo"
Could there be some problem with the Windows OS. Probably it is not allowing to start the service turbo ?. The port used by turbo is 1526.

What could be the problem. How to debug this ?
__________________
Vineet

Last edited by patvdv : 11th October 2004 at 10:23. Reason: Added CODE tags
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Restore informix database Han Brinkman Operating Systems & Databases 6 24th February 2017 05:44
How to split Baan Application and Baan Database ? baaniac Operating Systems & Databases 4 2nd June 2009 04:48
Problem with Informix Float Columns Dave Donovan Operating Systems & Databases 0 11th October 2004 17:29
Informix: Backup problem (ontape) MarioS Operating Systems & Databases 1 21st February 2003 16:24


All times are GMT +2. The time now is 23:51.


©2001-2017 - Baanboard.com - Baanforums.com