Baanboard.com

Go Back   Baanboard.com > Forum > BB Language Forums > Forum español

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 14th July 2004, 18:34
fbernaus's Avatar
fbernaus fbernaus is offline
Junior Member
 
Join Date: Jun 2002
Location: Azpeitia - Spain
Posts: 27
fbernaus is on a distinguished road
Baan: Baan IVc4 - DB: Oracle 8.0.3 - OS: HP-UX 11.0, NT 4.0
CUrioso problema con función AFS find

Hemos automatizado con las funciones AFS la sesión "tdinv1101m000" para realizar traspasos entre almacenes. Ahora, tenemos un problema muy curioso. Imaginaros que queremos realizar un traspaso del artículo 1234567 del almacén 111 al almacén 222. Pues bien, la primera vez que se intenta este traspaso la función AFS "find" devuelve un -1, es decir, no encuentra el artículo. Sin embargo, el artículo existe!
Lo curioso está en que las sucesivas veces que hacemos el mismo traspaso si se encuentra el articulo. Es justo en la primera cuando no lo encuentra!!!

¿Os ha pasado alguna vez algo parecido? Por favor, ayuda!! No sabemos en absoluto que es lo que está pasando para que pase eso tan raro. Muchas gracias por adelantado!!!

A continuación, pongo el código que utilizamos hasta lo que es la localización del artículo:

Dim baanobj As Object=CreateObject("Baan4.Application.baanivc4") '501
Dim sesion_baan As String = "tdinv1101m000" 'SESION: Introducir transacciones de stock por artículo

stpapi.put.field(sesion_baan,"tdinv100.item",codigo_articulo) //El codigo existe
stpapi.put.field(sesion_baan,"tdinv100.cwar",almacen origen)//el almacen que en el ejemplo llamo 111.
stpapi.find(sesion_baan)<<<<----- Aquí devuelve un -1 de artículo no encontrado!!
Reply With Quote
  #2  
Old 20th July 2004, 09:36
dorleta's Avatar
dorleta dorleta is offline
Senior Member
 
Join Date: Dec 2001
Location: Madrid - Spain
Posts: 133
dorleta is on a distinguished road
Baan: BaanIV - DB: All - OS: All
¿has probado a metrle una fecha ? el campo fecha forma parte también del indice e incluso no estaría de más ponerle un número a la secuencia ( que podría ser un 1 ) a ver que pasa.

Suerte
Reply With Quote
  #3  
Old 3rd October 2007, 16:11
gget79 gget79 is offline
Senior Member
 
Join Date: Nov 2006
Posts: 263
gget79 is on a distinguished road
Baan: 5 - DB: ORACLE - OS: UNIX
Podría ser que el campo item pertenece a un ámbito segmentado, y puede ser que en la primera ejecución la variable que toma el código del item no este formateado acorde al ámbito segmentado, te recomiento que realices un debbuger bajando a variables los datos y verificando que los espacios a la izquierda o la derecha sean igual que por el código que estan preguntando en el AFS.
Reply With Quote
Sponsored Links
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Find values en tdrpl0114m000 with AFS doesn't OK amtolo AFS/DDC/OLE: Function servers 3 11th July 2006 15:04
Duda con AFS fbernaus Forum español 4 29th June 2004 17:34
Find not working in AFS pinakin AFS/DDC/OLE: Function servers 2 29th November 2002 06:43


All times are GMT +2. The time now is 11:55.


©2001-2017 - Baanboard.com - Baanforums.com