Go Back > Forum > Baan SIGs > AFS/DDC/OLE: Function servers

User login

Frontpage Sponsor


Google search

For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
Installation Wizard into new VRC
Manual into existing VRC
Manual into new VRC
Total votes: 38

Baanboard at LinkedIn

Reference Content

Thread Tools Display Modes
Old 26th April 2004, 10:37
ayushkumar's Avatar
ayushkumar ayushkumar is offline
Join Date: Jan 2004
Posts: 2
ayushkumar is on a distinguished road
Baan: Baan IV - DB: Informix - OS: Sun Solaris
Post Problem of Saving View Field using AFS

Hi everyone,

I am a learner in AFS. I got stuck in my project because of the following problem.

I created a session in Baan with form type for this being 3. Now, I want to develop the same session in ASP page. For this I am using AFS for connecting Baan with ASP.

Here I have used put.field() function for inserting all the values from ASP page to Baan.

After entering the values of the view field, I am using change.view() function of AFS to set the current view for session.

After that I am using put.field() for all the remaining fields.

Then I am calling the save function of the AFS.

The problem that I am facing is that, except the view fields of the session the remaining fields are getting saved.

I want to save the content of the view fields as well.
What shall I do?

Kumar Ayush
Reply With Quote
Sponsored Links
Old 26th April 2004, 22:37
mark_h's Avatar
mark_h mark_h is offline
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 6,984
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris

I would re-send the view fields also - at least that is what I typically do. So you can just cut and paste the stpapi.put fields.

Reply With Quote
Old 27th April 2004, 08:28
ayushkumar's Avatar
ayushkumar ayushkumar is offline
Join Date: Jan 2004
Posts: 2
ayushkumar is on a distinguished road
Baan: Baan IV - DB: Informix - OS: Sun Solaris
Dear Mark,

Thanks for the reply.

I tried the same thing of cutting and pasting the stpapi.put.field() for different fields after the change.view() function call.

Then also it is not saving the data of the view fields, while data for the remaining fields is being saved in Baan.

Any other solution???

Kumar Ayush
Reply With Quote
Old 27th April 2004, 09:15
LittleJohn's Avatar
LittleJohn LittleJohn is offline
Senior Member
Join Date: Oct 2001
Location: CA
Posts: 184
LittleJohn is on a distinguished road
Baan: Baan4c2, Baan Vc - DB: SQL 2000, 7.0 - OS: Win 2003, Win2K Adv Server

you might want to first try to find the view fields you just inserted.
If you put() field values only in the view fields, the change.view(0 should save it.
Try to find the same record with the api func find().
btw, on which session are you trying to create this FS for ?

Reply With Quote
Old 16th November 2004, 19:16
Jacsccb's Avatar
Jacsccb Jacsccb is offline
Junior Member
Join Date: Mar 2003
Posts: 3
Jacsccb is on a distinguished road
Baan: BaanIVc4 - DB: MSSQL7.0 - OS: NT4

I'm a portuguese baan user, and it's hard to get
good documentation about Baan OLE Automation,
FS and Those features working on ASP pages.

Can you send me please some simple examples of
using AFS with ASP?

Thanks in advance.
Reply With Quote
Old 17th November 2004, 00:13
lakoon's Avatar
lakoon lakoon is offline
Senior Member
Join Date: Jul 2003
Location: Switzerland
Posts: 179
lakoon is on a distinguished road
Baan: Triton 2.0, Baan IV b/c /ERP /ERP LN - DB: Oracle / tbase / MSSQL - OS: Solaris / HP /Windows
Hello ayushkumar

Do you put the value to the correct field name?
Did you check the result of change.view (1 or 2). If 2 you are not positioned to the correct record.

May have a look at AFSLOG file, theire you will find hints on what is going on.

Use AFSLOG=1 as bshell start option.

Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem while running tfcmg2100s000 through AFS arunprasath AFS/DDC/OLE: Function servers 10 21st February 2008 18:16
problem with AFS (tfgld1101m000) garias AFS/DDC/OLE: Function servers 3 3rd May 2004 02:57
checking field only when saving wjfisch Tools Development 1 19th February 2003 15:47
view field - enable / disable fields ayoobi Tools Development 2 2nd September 2002 07:08

All times are GMT +2. The time now is 20:39.

©2001-2017 - -