Baanboard.com

Go Back   Baanboard.com > Forum > BB Language Forums > Deutsches Forum

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 6th March 2001, 00:00
Kai's Forum Users Kai's Forum Users is offline
Generic User
 
Join Date: Jan 1999
Posts: 2,115
Kai's Forum Users is on a distinguished road
IVc4, SQL-Server 7: Probleme mit Umlauten in Indicees


Hallo,wir haben BIVc4 auf SQL-Server 7 zu laufen und bekommen beim Zugriff auf Daten über einen ASCII-Index teilweise Fehler (Suchen, Blättern), wenn Umlaute in Schlüsseln stecken (z.B. Suchbegriff Kunde oder andere Schlüssel mit Umlauten).
Das jeweilige Programm bricht mit "Wrong row returned (305)" ab.

Das klappt auch ganz simpel beim Blättern mit General Table Maintenance.
Die Fehler treten mit demselben Datenbestand nur auf dem SQL-Server auf, mit ORACLE gibts keine Probleme. Abfragen mit der SQL-Console direkt am Server laufen sauber, auch wenn ich nach dem Hash-Wert des entspr. Index ordnen lasse.
Kennt jemand dieses Verhalten? Neues Portingset (6.1c.05.02) hat nicht geholfen.Uwe

Reply With Quote
  #2  
Old 8th March 2001, 00:00
Kai's Forum Users Kai's Forum Users is offline
Generic User
 
Join Date: Jan 1999
Posts: 2,115
Kai's Forum Users is on a distinguished road
Re: IVc4, SQL-Server 7: Probleme mit Umlauten in Indicees

Hallo,
wir haben auch dieses Problem gehabt. (AIX, Informix 7.36, Baan IVc4).
Geholfen hat: User verwalten in Baan, Seite 3, Locale: ISO_BIN. Allerdings sehen
danach die Suchmasken in Baan etwas "wild" aus. (Statt ZZZZZ steht überall yyyyy mit Ü-Strichen). Vielleicht hilft es euch ja auch...

Reply With Quote
Sponsored Links
  #3  
Old 9th March 2001, 00:00
Kai's Forum Users Kai's Forum Users is offline
Generic User
 
Join Date: Jan 1999
Posts: 2,115
Kai's Forum Users is on a distinguished road
Danke für den Tipp mit der Codepage


Hallo,
in der Ecke hätte ich nicht gesucht, wohl eher noch bei den Server-Einstellungen.>Locale: ISO_BIN. Allerdings sehen

>danach die Suchmasken in Baan etwas "wild" aus. (Statt ZZZZZ steht überall yyyyy mit Ü-Strichen). Vielleicht hilft es euch ja auch...
Bann schränkt beim Select wohl auf den in Suchbereich angegebenen Zeichenvorrat ein, der stand für ISO-8859-1 bei uns auf 1--127, Umlaute liegen eben dahinter. Wenn Ihr das komische Y nicht sehen wollt, kann man den Bereich nach oben auf den letzten sinnvollen deutschen Buchstaben (ü) begrenzen (dazu Max-Werte für ISO-BIN in tttss0104m000 auf 252 setzen, mit tttss0103m000 Runtime-Dateien davon erzeugen, user neu einloggen). Schränkt man auf "Z" ein, findet man natürlich keine Datensätze mehr, die mit Umlauten beginnen, das ist also nicht sinnvoll.Also nochmal Danke und tschuess

Uwe

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SQL Server 7.0 SP4 + BaanERP compatiblity Jabran Tools Administration & Installation 1 4th October 2004 11:49
Decision Manager & SQL Server 7.0 BisBoy Open World, Portal & Decision Manager 0 10th July 2003 13:11
BAANERP 5.0c and SQL Server 2000 installation isimeon Tools Administration & Installation 2 5th June 2003 08:18
Upgrade Baan IV (HP-UX, SQL Server 2000) cfasini Operating Systems & Databases 3 20th May 2003 13:56
Should Baan provide a level 2 database driver for SQL server 2000 on BaanIVc4? patvdv Polls and Surveys 6 28th March 2003 13:22


All times are GMT +2. The time now is 19:20.


©2001-2017 - Baanboard.com - Baanforums.com