Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Operating Systems & Databases

User login

Frontpage Sponsor

Main

Poll
As a Customer What would do to keep your ERP Implementation intact
Proactively define Business Process-- Take the Project Ownership
67%
Handover everything to System Integrator from drawing BP till implementation of ERP
0%
Hire more inhouse skilled & capable IT Resource to work directly with SI
33%
Rely on SI Architects/Consultants
0%
Total votes: 6

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 21st April 2002, 15:48
maximus's Avatar
maximus maximus is offline
Member
 
Join Date: Apr 2002
Location: Bear, DE, USA
Posts: 77
maximus is on a distinguished road
Baan: Most - DB: Most - OS: Most
Exclamation Creation of a baan user linked to a databse user

Hi,

Good to have such a nice forum to discuss things.

Right now I am stuck in a problem of creating a database user which is linked to a baan user. I have tried to create the user in the following ways.

1. through baan dba module.
2. by inserting entries in ora_users file , using encrypt6.2 & also creating the corresponding user in the oracle env & granting it the connect role.

3. using the ora_admin / maint scripts.

All these methods lead to one error 514.

My current baan env is

version baan erp 5.0b
Os - solaris
oracle 8 on unix

I have to deliver the installed servers by tommmorow. anyhelp in this matter is appreciated.

thanking you in advance

regards
max
Reply With Quote
  #2  
Old 21st April 2002, 18:44
alejandro's Avatar
alejandro alejandro is offline
Senior Member
 
Join Date: Feb 2002
Location: Madrid - Spain
Posts: 144
alejandro is on a distinguished road
Baan: IV c4 - DB: Oracle 8 - OS: Unix
ERROR 514

514 ESECURITY (ORACLE)
Security error; probably no user / group permission

I cannot help you more than post here what 514 error code means.

Maybe other guys can post more Info.

Good Luck.
Reply With Quote
  #3  
Old 21st April 2002, 23:30
Nicholas's Avatar
Nicholas Nicholas is offline
Member
 
Join Date: Apr 2002
Posts: 30
Nicholas is on a distinguished road
There are a couple of things you can do to get around or solve this error.
1. Edit the Ora_users file. Copy a line in the file and edit it to reflect the new user you are adding.
bsp:bsp:encrypted_password:baan_group
to
new_user:bsp:encrypted_password:baan_group

2. Check out authorization into Oracle. Make sure the baan_group is in Oracle.
2.1 Make sure the new_users is in oracle and has authorizations to connect, and has the role/membership of the baan_group.
2.2 Make sure the encypted_password is equal to the password in Oracle.
Reply With Quote
  #4  
Old 22nd April 2002, 04:44
maximus's Avatar
maximus maximus is offline
Member
 
Join Date: Apr 2002
Location: Bear, DE, USA
Posts: 77
maximus is on a distinguished road
Baan: Most - DB: Most - OS: Most
Creation of DB Users in BaaN ERP - NLS parameter not set

I have checked the following things in the current environment.

1. the user is present in baan & unix.
2. using the dba module in baan I an not able to create a entry in the ora_users file. It fires an error Invalid username / password. Error 12705. This error is logged in the log.ora8_maint.. file.
3. I have tried creating user & grp at oracle level & then in baan & then trying to link these two. But the I get the same error.

Any inputs will be helpfull.

max
Reply With Quote
  #5  
Old 22nd April 2002, 11:16
patvdv's Avatar
patvdv patvdv is offline
Board Master
 
Join Date: Aug 2001
Location: Belgium
Posts: 2,176
patvdv is on a distinguished road
Baan: n/a - DB: n/a - OS: AIX, HP-UX, Linux
Maximus,

Is your $BSE/lib/ora/ora_groups properly configured? Is your baan 'group' user able to logon to the database? e.g. you can test this by creating a dummy table using the session 'create tables'.
__________________
Regards,

Patrick Van der Veken - Admin & Founder - (c) 2001-2020 baanboard.com/baanforums.com
Reply With Quote
  #6  
Old 22nd April 2002, 14:43
maximus's Avatar
maximus maximus is offline
Member
 
Join Date: Apr 2002
Location: Bear, DE, USA
Posts: 77
maximus is on a distinguished road
Baan: Most - DB: Most - OS: Most
Creation of DB Users in BaaN ERP - NLS parameter not set

Yes my baan group user is able to logon to the oracle db.

Thruogh baan as well as through oracle sqlplus.

But I still could not get the baan user converted to db user.

I am still facing the NLS parameter issue.

If any other info might be usefull in resolving the problem please do write back, I will be happy to provide the info.

thanks, all of you.
regards
max
Reply With Quote
  #7  
Old 22nd April 2002, 15:39
Djie-En's Avatar
Djie-En Djie-En is offline
Senior Member
 
Join Date: Apr 2002
Location: The Netherlands
Posts: 197
Djie-En is on a distinguished road
Baan: BaanIVc4 - DB: Oracle11.2 - OS: AIX6.1
Re: Creation of DB Users in BaaN ERP - NLS parameter not set

Is Your BAAN-user the same as the ORACLE-user?
If so, the $BSE/lib/ora/ora_users file should contain:
<baanuser>:<oracleuser>:<encrypted password>:<baan group>
p.e.: bsp:bsp:4QAVtL3vQ\U)CR}eXW*Tz5D&6Y1T8Z:baan
or ab12345:ab12345:4QAVtL3vQ\U)CR}eXW*Tz5D&6Y1T8Z:baan

Regards,

D.E.
Reply With Quote
  #8  
Old 22nd April 2002, 16:03
ericthomas ericthomas is offline
Member
 
Join Date: Apr 2002
Location: United Kingdom
Posts: 87
ericthomas is on a distinguished road
Baan: c4 sp11 - DB: oracle8i - OS: HP11
ora8_admin6.1 not working !

I also have the same requirement and tried ora8_admin6.1 script and it is jumping/spreading all over the screen and not able to type somthing!

To add a new user to existing group copy and paste the previous line would do but the new group is difficult.

When you cut and paste make sure the carriage returns and properly done in places.

Last edited by ericthomas : 22nd April 2002 at 16:21.
Reply With Quote
  #9  
Old 22nd April 2002, 16:25
patvdv's Avatar
patvdv patvdv is offline
Board Master
 
Join Date: Aug 2001
Location: Belgium
Posts: 2,176
patvdv is on a distinguished road
Baan: n/a - DB: n/a - OS: AIX, HP-UX, Linux
To use the ora8_admin tool you must set your TERM properly first (VT100)

Maximus, what is the NLS issue you have?
__________________
Regards,

Patrick Van der Veken - Admin & Founder - (c) 2001-2020 baanboard.com/baanforums.com
Reply With Quote
  #10  
Old 22nd April 2002, 18:37
NPRao's Avatar
NPRao NPRao is offline
Guru
 
Join Date: Aug 2001
Location: Pacific NW, USA
Posts: 3,120
NPRao will become famous soon enough
Baan: Baan 4-5,5.2(Reger),LN-6.1,Infor LN-10.x - DB: Oracle,MS-SQL - OS: HPUX, Linux, Windows
BaaN recommends the NLS settings as

nls_lang:american_america.we8iso8859p1

and NOT

AMERICAN_AMERICA.US7ASCII

We had problem with corrupted report layouts that I encountered this issue. Here are the case details from the BaaN Support site -

Quote:
Error "Index n out of dims[n] n " on form, report, menu layout tables on ORACLE
Author T Chakrab Creation Date: 11 Mar 1998 Alternate ID:
Solution No: 1955 Solution Version: 1.0 Status: Published
Product: ttB40b Sub Product: ttadv Session: advformedit
Package: tt Version: B40 Release: b
Solution Type: PAR REPORT
Symptom information
VAT report with errors
Index out of dims error when trying to maintain a report layout
ttadv335.layo index 284 out of dims (1) 260
__________________
The art of perfection does not lie in doing extraordinary things but, doing ordinary things extraordinarily well. [-N. Prashanth Rao]
How To Ask Questions The Smart Way,BaaNBoard,NPRao

Last edited by patvdv : 22nd April 2002 at 21:56.
Reply With Quote
  #11  
Old 22nd April 2002, 22:01
patvdv's Avatar
patvdv patvdv is offline
Board Master
 
Join Date: Aug 2001
Location: Belgium
Posts: 2,176
patvdv is on a distinguished road
Baan: n/a - DB: n/a - OS: AIX, HP-UX, Linux
NPROa,

I had to shorthen your post because the layout was, well a bit messed up. The NLS character set choice depends really on your application needs. You could still use US7ASCII. The important thing is that you keep the NLS settings compatable on database, server and client level. The index out of dims error is caused by updating the tables ttadv334/ttadv335/ttadv364 with conflicting NLS settings. Reason for that is it messes up the binary 'layout' fields of these tables.

For characterset my recommendation however would also be to use WE8ISO8859P1 or similar.
__________________
Regards,

Patrick Van der Veken - Admin & Founder - (c) 2001-2020 baanboard.com/baanforums.com
Reply With Quote
Sponsored Links
  #12  
Old 22nd April 2002, 22:10
NPRao's Avatar
NPRao NPRao is offline
Guru
 
Join Date: Aug 2001
Location: Pacific NW, USA
Posts: 3,120
NPRao will become famous soon enough
Baan: Baan 4-5,5.2(Reger),LN-6.1,Infor LN-10.x - DB: Oracle,MS-SQL - OS: HPUX, Linux, Windows
Hi Pat,

Its NPRao ;-)

and thanks for formatting the post.

Can you please explain the cause and effect, background info about the different NLS settings. I didnt get any much info from BaaN on this topic, perhaps you can share your knowledge here.

Thanks!
__________________
The art of perfection does not lie in doing extraordinary things but, doing ordinary things extraordinarily well. [-N. Prashanth Rao]
How To Ask Questions The Smart Way,BaaNBoard,NPRao
Reply With Quote
  #13  
Old 23rd April 2002, 09:26
maximus's Avatar
maximus maximus is offline
Member
 
Join Date: Apr 2002
Location: Bear, DE, USA
Posts: 77
maximus is on a distinguished road
Baan: Most - DB: Most - OS: Most
Thumbs up Creation of DB Users in BaaN ERP - NLS parameter not set

Hi All,

Right now I have manually added the required users to the ora_users file. I am not very sure when the user might face a problem becasue of this. I have about a week with me to get the right solution so keep you thinking caps on & pour in your ideas. I will try out the NLS config suggested .

If any other input is needed from me on this problem please post a message & I will get back.

Thank you for the help, keep them coming.

max
Reply With Quote
  #14  
Old 23rd April 2002, 09:44
ericthomas ericthomas is offline
Member
 
Join Date: Apr 2002
Location: United Kingdom
Posts: 87
ericthomas is on a distinguished road
Baan: c4 sp11 - DB: oracle8i - OS: HP11
Known issues with copying ora_user line.

Dear All,

Copying ora_user is a standard procedure recommended by implementation partner to non baan administrators and no problems in last 12months!

Only thing no information stored in dba tables for this addition and next time do the same to link a baan user to db user.
Reply With Quote
  #15  
Old 23rd April 2002, 11:15
patvdv's Avatar
patvdv patvdv is offline
Board Master
 
Join Date: Aug 2001
Location: Belgium
Posts: 2,176
patvdv is on a distinguished road
Baan: n/a - DB: n/a - OS: AIX, HP-UX, Linux
One out of 2

Maximus,

One thing to keep into account is that you should make a choice as how to add/delete users: either you use the DBA module in Baan and convert to runtime - or - you manually manipulate the ora_users file each time. You will definatively get problems when you switch between both methods.

NPRao, I will see if I can dig up a document that describes the NLS issues very well.
__________________
Regards,

Patrick Van der Veken - Admin & Founder - (c) 2001-2020 baanboard.com/baanforums.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to create baan user ?? hendra Tools Administration & Installation 11 16th December 2005 10:38
BaaN V create user Alick Wilson Tools Administration & Installation 1 2nd August 2004 20:56
Error 510 when create new user h3nry_99 Tools Administration & Installation 12 24th November 2001 14:25
BSP-US (LLC) added as a Baan Education Alliance svandenh General Discussion & Chat 1 20th August 2001 19:44


All times are GMT +2. The time now is 23:05.


©2001-2018 - Baanboard.com - Baanforums.com