Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
37%
Installation Wizard into new VRC
39%
Manual into existing VRC
3%
Manual into new VRC
21%
Total votes: 38

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 15th November 2017, 17:00
srkndnsn srkndnsn is offline
Junior Member
 
Join Date: Aug 2016
Posts: 9
srkndnsn is on a distinguished road
Baan: Infor Ln10.4 - DB: Oracle - OS: Unix
Using LN Studio and debug in web ui
Baan: ERP LN 6.1 FP10 (Infor ERP 10.4)
C/S: Both

Hi everyone,

We are want use Webui for develop and debug. When i try to open script webui, the error occurs;

--Session ttadv2130s0000 is not supported in this version of LN UI-

I searched that error in Infor Extreme and someones also faced that problem. They said, you need LN studio for edit/view scripts.(https://www.inforxtreme.com/espublic...om=KBFavorites) So, does the LN Studio any requirements like tool version or something else? Does anyone have experiences with LN Studio?

Any suggestions on a good way to approach this?

Regards,
Serkan
Reply With Quote
  #2  
Old 16th November 2017, 11:33
sasikanth's Avatar
sasikanth sasikanth is offline
Senior Member
 
Join Date: Jul 2009
Location: Hyderabad, Andhra Pradesh, India
Posts: 149
sasikanth is on a distinguished road
Baan: L.N 6.1 FP7, 10.3, 10.4 & 10.5 - DB: SQL Server - OS: Windows
Hi Serkan,

You can't use WEBUI for Development. However, you can use WEBUI for debugging by following specific steps.

Though Infor suggests to use LN Studio for Development, you can use BECS for development. This is much easier than LN Studio.

To use LN Studio, you need to have little knowledge about ECLIPSE.
__________________
Sasi Kanth V
Infor ERP LN Solution Architect

Reach Me Out on LinkedIn | Never Miss an Update from LN Campus YouTube Channel
Reply With Quote
  #3  
Old 17th November 2017, 15:34
srkndnsn srkndnsn is offline
Junior Member
 
Join Date: Aug 2016
Posts: 9
srkndnsn is on a distinguished road
Baan: Infor Ln10.4 - DB: Oracle - OS: Unix
Hi Sasi,

I see your point, but why they said you need LN studio for that in Infor Extreme. Beside that we cant debug also in webui.

Quote:
Originally Posted by sasikanth View Post
Hi Serkan,

You can't use WEBUI for Development. However, you can use WEBUI for debugging by following specific steps.

Though Infor suggests to use LN Studio for Development, you can use BECS for development. This is much easier than LN Studio.

To use LN Studio, you need to have little knowledge about ECLIPSE.
Reply With Quote
  #4  
Old 17th November 2017, 16:27
bhushanchanda's Avatar
bhushanchanda bhushanchanda is offline
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,322
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
You can debug in WebUI

1. Run Connector Daemon (ottstpcondaemon) from your Worktop/BECS.
2. Click on Listen
3. Note down the port number
4. Open WebUI using a slightly different link e.g.

Instead of http://<WebUIAddress>/webui/servlet/login use http://<WebUIAddress>/webui/servlet/debugLogin.

Now, just open the session which is under debug and it will work.
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
  #5  
Old 18th November 2017, 06:10
sasikanth's Avatar
sasikanth sasikanth is offline
Senior Member
 
Join Date: Jul 2009
Location: Hyderabad, Andhra Pradesh, India
Posts: 149
sasikanth is on a distinguished road
Baan: L.N 6.1 FP7, 10.3, 10.4 & 10.5 - DB: SQL Server - OS: Windows
Debugging in Web UI / LN UI

Hi Serkan,

Refer the KB 1495758 on InforXtreme for more details about the procedure to debug the sessions running inside Ming.le/LN UI.

Coming to your other query on Development using LN Studio, though Infor Suggests to use LN Studio (Which is a Standardized Platform for Development), you can still use BECS for Development.

Let me know if you need more details.
__________________
Sasi Kanth V
Infor ERP LN Solution Architect

Reach Me Out on LinkedIn | Never Miss an Update from LN Campus YouTube Channel
Reply With Quote
  #6  
Old 20th November 2017, 08:02
srkndnsn srkndnsn is offline
Junior Member
 
Join Date: Aug 2016
Posts: 9
srkndnsn is on a distinguished road
Baan: Infor Ln10.4 - DB: Oracle - OS: Unix
I tried also what you said. I found these knowlodge base from Infor Extreme (KB 1666332, KB 1495758,KB 809503). But after the configured the deamon session,when I changed the link with debugLogin, i see HTTP Status 404 page. Do we need to do more things for see the debug page in webui mode?

Quote:
Originally Posted by bhushanchanda View Post
You can debug in WebUI

1. Run Connector Daemon (ottstpcondaemon) from your Worktop/BECS.
2. Click on Listen
3. Note down the port number
4. Open WebUI using a slightly different link e.g.

Instead of http://<WebUIAddress>/webui/servlet/login use http://<WebUIAddress>/webui/servlet/debugLogin.

Now, just open the session which is under debug and it will work.
Reply With Quote
  #7  
Old 20th November 2017, 08:19
bhushanchanda's Avatar
bhushanchanda bhushanchanda is offline
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,322
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
Error 404 means the page is not found.

Are you closing the Worktop/BECS after you run the Daemon session? You have to keep it running in the background when you try to access the WebUI Link. Once the page gets opened up, you have to put the port number you get on your session.
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
  #8  
Old 21st November 2017, 07:45
srkndnsn srkndnsn is offline
Junior Member
 
Join Date: Aug 2016
Posts: 9
srkndnsn is on a distinguished road
Baan: Infor Ln10.4 - DB: Oracle - OS: Unix
No I dont close to deamon session. After the session start to listen, i entered the debugLink then 404 not found. I have searched from Tomcat engine, this page not serviced or i cant find it.

Quote:
Originally Posted by bhushanchanda View Post
Error 404 means the page is not found.

Are you closing the Worktop/BECS after you run the Daemon session? You have to keep it running in the background when you try to access the WebUI Link. Once the page gets opened up, you have to put the port number you get on your session.
Reply With Quote
  #9  
Old 21st November 2017, 08:13
bhushanchanda's Avatar
bhushanchanda bhushanchanda is offline
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,322
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
Can you please tell me what link you are using?

You can leave your server name details off from the link. May be the link you are providing is not right.
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
  #10  
Old 21st November 2017, 13:07
srkndnsn srkndnsn is offline
Junior Member
 
Join Date: Aug 2016
Posts: 9
srkndnsn is on a distinguished road
Baan: Infor Ln10.4 - DB: Oracle - OS: Unix
I use this link : http://<myweb adress>/webui/servlet/debugLogin

Quote:
Originally Posted by bhushanchanda View Post
Can you please tell me what link you are using?

You can leave your server name details off from the link. May be the link you are providing is not right.
Reply With Quote
Sponsored Links
  #11  
Old 21st November 2017, 17:36
joanfuentes joanfuentes is offline
Junior Member
 
Join Date: Jul 2008
Posts: 11
joanfuentes is on a distinguished road
Baan: baan Iv, V, Ln - DB: baan Iv, V, Ln - OS: Windows 8.1
Hi Bhushan:

I read the post and i tried to make this works, but i have a message say connection refused, maybe i have to configure something before try use the debugger?

Tks

Reggards
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump


All times are GMT +2. The time now is 07:35.


©2001-2017 - Baanboard.com - Baanforums.com