Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
How big is your Baan-DB (just Data AND Indexes)
0 - 200 GB
17%
200 - 500 GB
29%
500 - 800 GB
3%
800 - 1200 GB
7%
1200 - 1500 GB
7%
1500 - 2000 GB
12%
> 2000 GB
24%
Total votes: 58

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2019, 17:01
baanjim baanjim is offline
Member
 
Join Date: Mar 2005
Posts: 37
baanjim is on a distinguished road
Baan: BaanERP - DB: oracle - OS: win2000(clt)-unix(srv)
Add TAB in QR Code
Baan: ERP LN 6.1 FP7 (Infor ERP 10.1)
C/S: None/Unknown

Hi,
I try to create a QR code and print it on BW Print.
My QR code contains 3 variables: cwar, item, qty. separated by a TAB character.
the code is:
qrcode = cwar & chr$(0x09) & item & chr$(0x09) & str$ (qrcr)
qrcode = bc$ (1010, 4, qrcode , BC2D_SET_MODE (0x01) + BC2D_SET_LEVEL (0x01) + BC2D_SET_COLUMNS (0x00))
The result is, in BW Print, that the QR code doesn't appear!
If I take off the Tab caracters, It works!
I also tried to generate a simple barcode 10 and in this case it works!
Thx for any help.
Regards.
Reply With Quote
Sponsored Links
  #2  
Old 16th April 2019, 17:50
bdittmar's Avatar
bdittmar bdittmar is offline
Guru
 
Join Date: Apr 2002
Location: Germany, 50.584097,8.544078
Posts: 1,764
bdittmar will become famous soon enough
Baan: 2.2/3.1/4c4/LN6.1 FP6/FP9/HiDox - DB: tbase, ms-sql7, oracle10gV1, 11g - OS: HP-UX, W2K3, SLES
chr$(09)

Quote:
Originally Posted by baanjim View Post
Hi,
I try to create a QR code and print it on BW Print.
My QR code contains 3 variables: cwar, item, qty. separated by a TAB character.
the code is:
qrcode = cwar & chr$(0x09) & item & chr$(0x09) & str$ (qrcr)
qrcode = bc$ (1010, 4, qrcode , BC2D_SET_MODE (0x01) + BC2D_SET_LEVEL (0x01) + BC2D_SET_COLUMNS (0x00))
The result is, in BW Print, that the QR code doesn't appear!
If I take off the Tab caracters, It works!
I also tried to generate a simple barcode 10 and in this case it works!
Thx for any help.
Regards.
Hello,
Quote:
Try to use chr$(09) instead of chr$(0x09)

chr$()
Syntax:

function string chr$ (long code)

Description


This function returns a single character string corresponding to the supplied code point.
Arguments
long code
Context
This function can be used in all script types.
Note
If code is greater than 255, the returned string is of type multibyte and the supplied code point is encoded into a four-byte sequence. No check is made on the legality of the value.
Example

chr$(65) | Returns "A"
chr$(asc("A")) | Returns "A"
chr$(27) | Returns the escape character
Regards
__________________
//Bernd
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Programming Question mr_suleyman Tools Development 37 11th November 2016 08:14
unable to add code through QKey VishalMistry Tools Development 4 19th July 2016 12:44
how to add computed field in a form without soucrce code ncgjiju Tools Development 7 26th August 2005 14:07
add description with a code?? jatin_sanghi Tools Development 1 31st January 2005 15:05


All times are GMT +2. The time now is 20:21.


©2001-2018 - Baanboard.com - Baanforums.com