Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
How big is your Baan-DB (just Data AND Indexes)
0 - 200 GB
18%
200 - 500 GB
30%
500 - 800 GB
3%
800 - 1200 GB
6%
1200 - 1500 GB
8%
1500 - 2000 GB
12%
> 2000 GB
23%
Total votes: 66

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 13th May 2019, 09:55
Henk Kwant Henk Kwant is offline
Junior Member
 
Join Date: May 2019
Posts: 3
Henk Kwant is on a distinguished road
Baan: B50c - DB: SQL - OS: Windows Server 2008 R2
Print detail in after field section

I some reports I use the following:
pdetail = 2
r.2.s.detail()
pdetail = 0

In a new report on another Baan server I want to use this command also but there I get error "Unresolved reference to r.2.s.detail()".

I believe that in the past the current command was a little bit different but I can't remeber what that was.

Can anyone help me on this matter?

Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 13th May 2019, 13:23
mark_h's Avatar
mark_h mark_h is offline
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 7,250
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
What first jumped into my mind was debug the report and make sure the routine is still present with that name.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #3  
Old 13th May 2019, 15:54
Henk Kwant Henk Kwant is offline
Junior Member
 
Join Date: May 2019
Posts: 3
Henk Kwant is on a distinguished road
Baan: B50c - DB: SQL - OS: Windows Server 2008 R2
I get the error message after compiling the report so I cannot debug anything (or do not know how to).
Reply With Quote
  #4  
Old 14th May 2019, 13:41
mark_h's Avatar
mark_h mark_h is offline
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 7,250
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
Sorry - should have said comment out the r.2.s.detail() line. Compile in debug - make sure that routine is still preset in the compiled report. If not I am assuming you have a system where this report works - compile that one in debug mode. And run both reports comparing the code. My swag and I could be wrong is the layout numbers or something must have changed between servers.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #5  
Old 15th May 2019, 07:57
günther günther is offline
Guru
 
Join Date: Jan 2002
Location: Ehingen, Germany
Posts: 587
günther is on a distinguished road
Baan: IVc4 - DB: Informix - OS: HP-UX
Hi,

I just had a look at one of my reports. I see a function r.s.detail, which then calls r.s.detail.1 (maybe other number, maybe more Detail lines) according to the defined layouts. But I'm not sure if i've ever seen r.2.s.detail.

Maybe you could use a standard method like: cope layout 1 to layout 2 and use print conditions?

Or you could try my solution described here:
http://www.baanboard.com/baanboard/showthread.php?t=9090&highlight=Advanced+Report


Regards
Günther
Reply With Quote
  #6  
Old 15th May 2019, 08:36
Henk Kwant Henk Kwant is offline
Junior Member
 
Join Date: May 2019
Posts: 3
Henk Kwant is on a distinguished road
Baan: B50c - DB: SQL - OS: Windows Server 2008 R2
Hello Gunther,
That's it. The report compiles now whitout errors.
Thanks for your help.
Kind regards,
Henk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need horizontal line in end of detail section when report display on multiple pages dharmendrayadav Tools Development 4 12th January 2015 04:25
Why to print "%" at field type double in report? somjit Tools Development 4 30th November 2007 09:11
print text field in the report linyaohui Tools Development 1 21st November 2007 10:10


All times are GMT +2. The time now is 01:33.


©2001-2018 - Baanboard.com - Baanforums.com