Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Google search


Poll
How big is your Baan-DB (just Data AND Indexes)
0 - 200 GB
17%
200 - 500 GB
17%
500 - 800 GB
6%
800 - 1200 GB
6%
1200 - 1500 GB
17%
1500 - 2000 GB
17%
> 2000 GB
22%
Total votes: 18

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 3rd December 2002, 14:36
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
Unhappy Single fields on multi-occ (type 3) form

Hi everyone.

Since I was not lucky getting answers a few days ago, decided to resubmit this problem. I am desperate...

I just created a Type 3 form on a new table. The standard type 3 form works ok.

Trying to put some single fields on the bottom of the form.
Cannot get the those fields displayed. What I am missing?

Here's what I have done so far:

The base table has 2 key fields. Lets call them key1 and key2.
The form draft is more or less like this:
===============
key1
--------------------------
key2 field1 ... fieldx
key2 field1 ... fieldx
...
key2 field1 ... fieldx
--------------------------
single1
single2
===============

Single1 and single2 are "display only" fields in the form.
Single1 and single2 are extern script variables.
Here are the relevant parts of the script:

declaration:

extern domain tcitem single1
extern domain tcdsca single2

before.program:
single.fields.on.mocc.form("single1","single2")

field.key2:
after.display:
single1 = tdmcm011.item

select tiitm001.dsca:single2
from tiitm001
where tiitm001._index1 = {:tdmcm011.item }
selectdo
endselect

display("single1")
refresh()
display("single2")
refresh()



The values for single1 and single2 calculated ok in the script. I checked via debugger. (However each display statement steps 5 times)


Can someone give me a hand?

Thanks a lot
Fred
__________________
The Sleeper has Awakened.
Reply With Quote
  #2  
Old 3rd December 2002, 14:56
evesely's Avatar
evesely evesely is offline
Guru
 
Join Date: Dec 2001
Location: Lisle, Illinois USA
Posts: 412
evesely is on a distinguished road
Did you check to make sure that these fields are not being hidden by your multi-occurrence fields? Try just temporarily putting these fields at the top of the form and see if they display. There is a setting on form 2 of the Maintain Forms session to adjust the number of rows to display.
Reply With Quote
Sponsored Links
  #3  
Old 3rd December 2002, 15:36
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
Unhappy Tried it. Problem still exists.

Thanks Ed, for your prompt reply.

Tried your suggestion.

Put the two single fields on top of the form.
The fields are displayed, but instead of once, they are displayed 5 times (the number of occurrences of the form), line after line. (????)
single1 single2
single1 single2
...
(this must be the reason why the display statement in the script stepped 5 times in the debugger)

It seems I need to tell the program what occurence to put in the single fields (???). How can I do that?

However, when I put the single fields at the bottom. They are not displayed.


Thanks
Fred
__________________
The Sleeper has Awakened.
Reply With Quote
  #4  
Old 3rd December 2002, 15:48
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
One more thing...

Forgot to tell you one thing:

When I put the single fields on the top and push the multi-occ fields down, the single fields are displayed 5 times and the multi-occ fields are not displayed.

Fred
__________________
The Sleeper has Awakened.
Reply With Quote
  #5  
Old 3rd December 2002, 16:05
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
Talking Solved it. Ups...

Solved it.

The multi-occ check box on the single fields was checked. Unchecked it and now it works.

Thanks
Fred
__________________
The Sleeper has Awakened.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fields on Form LittleJohn Tools Development 4 13th May 2004 17:00
Baan & Connectware Driver Hangs Rajasekhar Tools Administration & Installation 2 18th February 2004 21:32
Single fields on type 3 form fmorais Tools Development 3 3rd December 2002 16:06


All times are GMT +2. The time now is 14:38.


©2001-2018 - Baanboard.com - Baanforums.com