Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
What version of Baan have you installed
Baan IV
35%
FP3
4%
FP4
0%
FP5
0%
FP6
0%
FP7
4%
10.2 (incl. 10.2.1)
0%
10.3
9%
10.4
17%
10.5
26%
Other
4%
Total votes: 23

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 29th November 2002, 18:02
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
Question Single fields on type 3 form

Hi everyone.

I just created a Type 3 form on a new table. The standard type 3 form works ok.

Trying to put some single fields on the bottom of the form. Cannot get the those fields displayed. What I am missing?

Here's what I have done so far:

The base table has 2 key fields. Lets call them key1 and key2.
The form draft is more or less like this:
--------------------------
key1 |
------ |
key2 field1 ... fieldx |
key2 field1 ... fieldx |
... |
key2 field1 ... fieldx |
------------------------ |
single1 |
single2 |
------------------------

Single1 and single2 are "display only" fields in the form.
Single1 and single2 are extern script variables.
In the script (field section) I have:

field.key2:
after.layout:

|Calculate single1
display("single1")
refresh()

|Calculate single2
display("single2")
refresh()

The values for single1 and single2 calculated ok in the script. I checked via debugger.

-------------------------------------------------------------------------
So my questions are as follows:

-The fields single1 and single2 are never displayed, even if I mark one record. What am I missing?

-When I have 5 occurences in the screen and none is marked, how can I know and control which one has the corresponding values on single1 and single2.


Can someone give me a hand? I'm a bit stuck...

Thanks
Fred
__________________
The Sleeper has Awakened.
Reply With Quote
  #2  
Old 29th November 2002, 19:48
lbencic's Avatar
lbencic lbencic is offline
Guru
 
Join Date: Dec 2001
Location: Lisle, IL, USA
Posts: 1,148
lbencic will become famous soon enough
Baan: 2.2d - LN - DB: most - OS: most
This post has info on single fields.

Fatal error
Reply With Quote
  #3  
Old 3rd December 2002, 15:23
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
Unhappy Did not Work...

Tried putting

single.fields.on.multi.occ.form(...) on the before.program section

Still it is not working.
What am I missing?

Thanks
Fred

P.S.: Will post a new thread about this with the updated info.
__________________
The Sleeper has Awakened.
Reply With Quote
Sponsored Links
  #4  
Old 3rd December 2002, 17:06
fmorais's Avatar
fmorais fmorais is offline
Senior Member
 
Join Date: Mar 2002
Location: Portugal
Posts: 164
fmorais is on a distinguished road
Baan: B4c4 - DB: MSSQL, Oracle, Informix, BBase - OS: Windows, AIX
Problem Solved.

Solved it.

The multi-occ check box on the single fields was checked. Unchecked it and now it works.

Thanks
Fred
__________________
The Sleeper has Awakened.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fields on Form LittleJohn Tools Development 4 13th May 2004 18:00
Baan & Connectware Driver Hangs Rajasekhar Tools Administration & Installation 2 18th February 2004 22:32
Single fields on multi-occ (type 3) form fmorais Tools Development 4 3rd December 2002 17:05


All times are GMT +2. The time now is 14:47.


©2001-2017 - Baanboard.com - Baanforums.com