Baanboard.com

Go Back   Baanboard.com > Forum > Baan Quick Support: Functional & Technical > Tools Development

User login

Frontpage Sponsor

Main

Poll
How big is your Baan-DB (just Data AND Indexes)
0 - 200 GB
18%
200 - 500 GB
29%
500 - 800 GB
3%
800 - 1200 GB
8%
1200 - 1500 GB
8%
1500 - 2000 GB
12%
> 2000 GB
23%
Total votes: 77

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 7th October 2019, 07:23
Arlina Arlina is offline
Member
 
Join Date: Feb 2019
Posts: 35
Arlina is on a distinguished road
Baan: Infor LN - DB: MSSql - OS: Windows
Connection Lost
Baan: Baan IVc
C/S: None/Unknown

Hi All,

I am facing this weird issue.
I have 5 dlls with similar logic. All of these are using the same domains/tables/flow of control etc. Only the main table selection is different as each of the dll is being used for creating different files depending upon selection on the session.
3 of these dlls are working completely fine by creating the files and transferring them to a local folder.
For the remaining 2 dlls, the files are getting generated on the server and return values of seq.close/seq.puts is also a success
But I am getting connection lost error (sometimes on server2client or clicking on any variable or just randomly)
I am debugging this thing for last 3 days with no success.
Can anyone please help me with this?

Thanks & Regards,
Arlina
Reply With Quote
  #2  
Old 7th October 2019, 09:56
günther günther is offline
Guru
 
Join Date: Jan 2002
Location: Ehingen, Germany
Posts: 595
günther is on a distinguished road
Baan: IVc4 - DB: Informix - OS: HP-UX
Hi Arlina,

in such cases, I would use logging to a file instead of debugging because that gives a different timing behaviour. I have a special logging function that opens a log file in append mode, writes to that file and closes the file - that's a little overhead, but I can always look into the log file and have no problems with buffered I/O.

Regards
Günther
Reply With Quote
  #3  
Old 7th October 2019, 16:40
mark_h's Avatar
mark_h mark_h is offline
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 7,373
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
I think Gunther recommendation is good. The only other thing I can think of is to use a tool like wireshark to track the connection from the baan server all the way to the client. See if that helps to find the component that might be failing or causing you to lose the connection. In the past we have found load balancers(1 node with issues) and other network devices causing a dropped connection. Never done it myself, but others have.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #4  
Old 7th October 2019, 17:39
Arlina Arlina is offline
Member
 
Join Date: Feb 2019
Posts: 35
Arlina is on a distinguished road
Baan: Infor LN - DB: MSSql - OS: Windows
Hi All,
Thanks, guys for all the help and guidance.
But it seems the issue is not with the network.
What we found is, if we add any separator in the file it works perfectly fine. But without separator(not even a space as a separator) some spaces are getting added in the file which causes the issue.
As per the requirement, the file should be without any separator(we have a fixed length defined for each file-field).
Any suggestions/help/guidance is highly appreciated.

Thanks & Regards,
Arlina
Reply With Quote
  #5  
Old 8th October 2019, 07:37
Arlina Arlina is offline
Member
 
Join Date: Feb 2019
Posts: 35
Arlina is on a distinguished road
Baan: Infor LN - DB: MSSql - OS: Windows
Let me explain the whole situation now.
We want to create a file with fixed-length file fields without any separator.
For example column parent= tccom010.pctf is of length 20. Even if it is blank it needs to occupy 20 blanks spaces in the file. We are presently using sprintf$("%*s",20,shiftl$(parent)
So the length of each data line to put into the file is always 3140 characters.
If we use any separator than there is no fixed-length file field and data line length is significantly reduced.
Can the size/formatting affect the behavior?
Reply With Quote
Sponsored Links
  #6  
Old 8th October 2019, 19:04
mark_h's Avatar
mark_h mark_h is offline
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 7,373
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
There is always a possibility of some unprintable characters getting hung up in a field some where causing the issue. I don't think a fixed length field should cause the issue. Not sure if it is possible, but can you check the file for something like that on the server side? That is about the only thing I can think of.
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #7  
Old 9th October 2019, 10:04
okneb1 okneb1 is offline
Junior Member
 
Join Date: Aug 2016
Posts: 28
okneb1 is on a distinguished road
Baan: Baan IV to LN 10.6 - DB: SQL or Oracle - OS: Win/Unix
I really doubt this will have any impact, but try adding "t" to the openmode in seq.open call if you don't have it already:

If you now have seq.open ("file", "w+"), try with:
seq.open ("file", "wt+")

Also try playing around with text.mode option in function server2client (We almost always have it on true)
server2client (string source, string dest, boolean text.mode [, boolean progress.window] [, boolean read.only])

Last edited by okneb1 : 9th October 2019 at 10:15.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection lost after updating porting set milindwadge Tools Administration & Installation 2 7th December 2010 02:29
Errno 32 Log_mesg: Connection to server lost: fd_write 11: nu inalfa01 Operating Systems & Databases 2 4th November 2005 10:17
Lost connection with bshell SLChen Tools Administration & Installation 0 17th June 2004 11:50
Connection with server lost. Reconnect ? TheYaz Operating Systems & Databases 1 29th July 2003 19:13
Connection to Server Lost Joy Conner Tools Administration & Installation 2 6th January 2003 19:32


All times are GMT +2. The time now is 06:07.


©2001-2018 - Baanboard.com - Baanforums.com