Baanboard.com

Go Back   Baanboard.com > Forum > Baan SIGs > Archiving & Multisite

User login

Frontpage Sponsor

Main

Google search


Poll
How big is your Baan-DB (just Data AND Indexes)
0 - 200 GB
18%
200 - 500 GB
26%
500 - 800 GB
3%
800 - 1200 GB
9%
1200 - 1500 GB
12%
1500 - 2000 GB
12%
> 2000 GB
21%
Total votes: 34

Baanboard at LinkedIn


Reference Content

Closed Thread
 
Thread Tools Display Modes
  #1  
Old 7th January 2002, 11:26
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
Use of tfgld4210m000 in c3 to purge integration transactions.

Does anybody have any experience of using tfgld4210m000 in c3 to purge integration transactions.

I am attempting to remove Integration Transactions from our history companies for 1999 which have been transferred from our live company to our history companies using the session tfgld4210m000 with the copy to history option.

The session returns "No data found" despite their being numerous records which I believe the session should be purging.

Attached is a word document showing the options I am using and an example of a record which is not being removed.

I can confirm that the Purchase Order does not exist in tdpur040.

Any assistance would be appreciated.

Regards
Neal Matthews
Intier Automotive - Project Leader
Attached Files
File Type: doc tfgld002.doc (98.0 KB, 53 views)
  #2  
Old 7th January 2002, 13:01
MariaC's Avatar
MariaC MariaC is offline
Guru
 
Join Date: Sep 2001
Location: South Africa
Posts: 386
MariaC is on a distinguished road
Baan: BaanIV, BaanV, BaanERPLN - DB: SQL, Oracle - OS: Unix, Windows
Hi Neal,

The records will not be deleted in the following cases :

- tfgld410.sint has a value <> tfgld.sint.posted (now changed to check tfgld418.sint instead)
- tfgld410.cprj has a value <> ""
- Purchase orders exist in Purchase Order table tdpur040
- Sales orders exist in Sales Order table tdsls040
- Production orders exists in Production Order table tisfc001
- Replenishment orders exists in Replinishment Order table tdrpl105

What version of Baan are you doing this on?
__________________
Regards
Maria
  #3  
Old 7th January 2002, 16:07
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
Hello,

I'm running this on Baan IV c3 and I believe that all the conditions are being met.

PO does not exist in tdpur040, the project is blank and tfgld418.sint = posted.

Any other ideas ?

Thanks
Neal Matthews
Intier Automotive - Project Leader
  #4  
Old 23rd January 2002, 15:11
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
I've now received a solution from support regarding this issue.

Despite loading the debug object for this session the support analyst still cannot see why the records in question are not being deleted. Although as the session successfully removes records for company 001 and not 002 we suspect that the problem may be related to the multicompany structure.

Anyway the final solution I've been given is to manually delete the records from tables tfgld410 and tfgld417 using GTM and use sql to produce a report of records deleted. My only concern regarding this solution is the fact that all the checks that tfgld4210m000 will not be run.

Has anybody else had to archive by actually deleting the records using GTM and are there any risks to referentail integrity by removing the integration transactions in this manner.

Regards
Neal Matthews
Intier Automotive - Project Leader
  #5  
Old 23rd January 2002, 17:33
isimeon isimeon is offline
Member
 
Join Date: Sep 2001
Posts: 96
isimeon is on a distinguished road
Baan: BAAN IV c3/4 - DB: Oracle 7.x/8.x - OS: Windows NT/2000
patch

There are many patches for this session.

E.g.
This is from sp8 for c4:

Solution: 106054
SITUATION IDENTIFIED IN:
"Archive and Purge Integration Transactions" (tfgld4210m000)

SITUATION DESCRIPTION:
In session tfgld4210m000, 'Archive and Purge Integration Transactions', the company number on the session header displays
as the archive company number. As a result, when archiving data, errormessage "No data within selection." appears.

SOLUTION DESCRIPTION:
In session tfgld4210m000, 'Archive and Purge Integration Transactions', the company number on the session header
displays as the current company number.


In your case on session header company is 101, history company - 102, original company from 002 to 002. In which company the session was started? Also in gld410 - company origin is 002 and financial company is 002. Are you using multi finance/multi logistic configuration? Check logical tables in Database management.
  #6  
Old 23rd January 2002, 17:54
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
Hello,

We do already have the latest version of this object.

I am running the session from company 101 which does have its tfgld410-418 shared with companies 102 etc. This is a multi / multi setup which is mirrored from our live companies 001 and 002.

I have moved the records in question from 002 (table tfgld410001) to 101 (tfgld410101) and I know that the records for 002 do exist in this table.

However according to support the session doesn't want to see these records in the table.

Cheers
Neal Matthews
Intier Automotive
  #7  
Old 23rd January 2002, 19:15
isimeon isimeon is offline
Member
 
Join Date: Sep 2001
Posts: 96
isimeon is on a distinguished road
Baan: BAAN IV c3/4 - DB: Oracle 7.x/8.x - OS: Windows NT/2000
something is wrong, but..

Hello,

I have the same situation (3 multi/multi companies). May be there is something wrong in gld00x tables in history companies or in shared tables. If you want e-mail me.
Sponsored Links
  #8  
Old 24th January 2002, 09:52
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
Hello,

Have you successfully ran this session in your setup from the archive companies to purge transactions.

If so I would certainly like to look at your logical table setup in your archive companies. Any chance you could mail this to me.

Regards
Neal Matthews
Intier Automotive
neal.matthews@intier.com
  #9  
Old 25th January 2002, 11:18
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
I'm now looking at the Print Integration Transactions session tfgld4410m000 in order to report on the transactions I may have to remove via GTM.

Intriguingly enough when running this session in 101 it also cannot find the integration transactions for 002 but when running in 102 does find the records in tfgld410101.

Unfortunately the archiving session tfgld4210m000 will not run in 102 as I get the error message tfglds0414 Invalid History Company. So the problem must be somewhere in my company setup.

Neal
  #10  
Old 25th January 2002, 16:35
Neal Matthews's Avatar
Neal Matthews Neal Matthews is offline
Guru
 
Join Date: Sep 2001
Location: Nottingham
Posts: 483
Neal Matthews is on a distinguished road
Baan: Baan IVc4 ags0 - DB: Informix 9.40 UC4 - OS: Sun Solaris 9
This problem has now been solved thanks to Ivan.

When trying to print integration transactions from company 101 I noticed the same problem whereby the print would not pick up company 002 transactions. However when I ran the report from company 102 the transactions were printed.

Therefore the answer is to run the session from 102 but when I tried to do this previously I received the error message "Invalid history company". At Ivan's suggestion I changed the history company to 000 in the company parameters the error message was cleared and the session ran OK purging the integration transactions.

Thanks to everyone
Neal Matthews
Intier Automotive
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Integration transactions problem rini pudjiastut Finance, Invoicing and Integration 3 29th July 2004 09:03
Integration Transactions faditimo Finance, Invoicing and Integration 1 18th February 2004 14:33
Audit trail from Finance to distribution Nazeem Finance, Invoicing and Integration 14 11th October 2002 05:18
Large No. of Integration Transactions despite Compression turned on baaniac Finance, Invoicing and Integration 5 16th January 2002 04:20


All times are GMT +2. The time now is 19:58.


©2001-2018 - Baanboard.com - Baanforums.com