Baanboard.com

Go Back   Baanboard.com > Forum > Baan SIGs > Performance & Tuning

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #1  
Old 18th February 2003, 22:38
r_nagu's Avatar
r_nagu r_nagu is offline
Senior Member
 
Join Date: Mar 2002
Location: ~
Posts: 231
r_nagu is on a distinguished road
Baan: BaaN IV - DB: Oracle 8 - OS: UNIX
Performance Issue...

Last week we synched our development oracle server with our production oracle server to get the same data as in production to development environment for better testing and testing of archiving. We basically copied all the data files from production server to development server. Everything went well except that now when we try to access some of the big tables (like tdpur045, tdpur051, tfgld410 etc), the performance is extremely slow. It takes few minutes to find a specific PO number in Maintain PO session.

I tried few things to fix this problem and among one of those fixes, Reorganizing tables (ttaad4225m000) seem to fix this problem. I did re-org on few tables and performance dramatically improved. So far this is the only fix which is working fine. But, if this is the only fix, I have to re-org the whole company and that might take days to complete.

Are there any other solutions you guys can think of to fix the problem?

Appreciate your help,
Thanks,
NS
Reply With Quote
  #2  
Old 18th February 2003, 23:23
lbencic's Avatar
lbencic lbencic is offline
Guru
 
Join Date: Dec 2001
Location: Lisle, IL, USA
Posts: 1,148
lbencic will become famous soon enough
Baan: 2.2d - LN - DB: most - OS: most
This works probably because it rebuilds the index and reference connections.

You can try running this from the command line, where you can specify your options, and people generally get better performance.

Search for bdbpre, bdbreconfig and bdbpost on this forum, or check the Baan documentation on those programs. The programs are in your bin directory, called bdbpre6.1, bdbreconfig6.1 and bdbpost6.1 if you are in unix and on c4. Slightly diff for NT and Baan V, but same basic names. Sorry, I don't have the syntax handy for a regular reconfigure.
Reply With Quote
  #3  
Old 19th February 2003, 08:24
Martin Martin is offline
Senior Member
 
Join Date: Aug 2001
Location: Germany
Posts: 135
Martin is on a distinguished road
Baan: IVc, ERP5c - DB: oracle 9i, 10g, 11g - OS: Windows, HP-UX, SLES8/9/10/11
which datafiles to you had copied ?
Only the datafiles with baan data and indexes or the whole database ?
If you had only copied the baan-data, you had to run an analyze table to create the statistics for the oracle optimizer (these are stored in some system tables and are not availible if you dont copy the whole database)

martin
Reply With Quote
  #4  
Old 19th February 2003, 16:17
r_nagu's Avatar
r_nagu r_nagu is offline
Senior Member
 
Join Date: Mar 2002
Location: ~
Posts: 231
r_nagu is on a distinguished road
Baan: BaaN IV - DB: Oracle 8 - OS: UNIX
Just the baan data...

Only the baan data.
I ran the statement “ANALYZE TABLE TTFGLD410100 COMPUTE STATISTICS” and it did compute statistics for the table but, the performance is the same.

Is there any thing else I need to turn on in order to compute statistics. Some parameters, .. etc., ?

Thanks for your help,
NS
Reply With Quote
Sponsored Links
  #5  
Old 19th February 2003, 16:57
James James is offline
Retired Founder
 
Join Date: Aug 2001
Location: Bristol, UK
Posts: 158
James is on a distinguished road
Baan: Triton,Baan IV,ERP - DB: Oracle 7/8i/9i - OS: HPUX,Tru64,Linux
Try generating statistics for ALL tables within the Baan schema.

You'll certainly need to do this, and, on a regular basis.

Also, I presume the database configuration for your Development and Production instances are the same?
__________________
James Gittins
(c) 2002 Baanboard.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Performance issue kv0512 Tools Development 1 30th October 2003 12:56
Intermittent performance issue tfacp2120s000 rosalbaperez Performance & Tuning 1 25th March 2003 09:11
Performance Issue... suhas-mahajan Performance & Tuning 2 18th March 2003 16:01
Performance issue while running DNC ! mraguthu Distribution, Transportation & Warehousing 0 1st April 2002 22:31
Performance issue while running EDI-DNC to create Sales Orders. How I resolve? mraguthu Tools Development 0 28th March 2002 19:08


All times are GMT +2. The time now is 21:24.


©2001-2017 - Baanboard.com - Baanforums.com