Baanboard.com

Go Back   Baanboard.com > Forum > Baan SIGs > Code & Utilities

User login

Frontpage Sponsor

Main

Poll
For ERP LN feature pack upgrade, what method of install are you using?
Installation Wizard into existing VRC
35%
Installation Wizard into new VRC
42%
Manual into existing VRC
3%
Manual into new VRC
19%
Total votes: 31

Baanboard at LinkedIn


Reference Content

Reply
 
Thread Tools Display Modes
  #31  
Old 4th April 2013, 23:36
mark_h's Avatar
mark_h mark_h is offline
Guru
 
Join Date: Sep 2001
Location: Kentucky, USA
Posts: 6,903
mark_h will become famous soon enough
Baan: Baan 4C4 A&D1 - DB: Oracle - OS: Sun Solaris
As per your PM about the log:

You can put the logo on the baan server where ever you want it to be. Then just make sure you set the right path in your driver file(the script uses HEADER). What I am not sure of is if the program actually explodes the ${BSE} - I think it does, but am not sure. Then if you use the script as it is it would download it to DEFAULT. Again default can be any path you can write the logo jpg into on the client. Then you would change the IMAGE_EMBED to the path of DEFAULT.

The issue I have is that I thought file.stat only looked on the BaaN server - not the local client. That could be different depending on your setup - not 100% sure. Here is how I check on 4c4 if a file exists on the client. If input file is less than 0 then it does not exist.
Code:
        inputfile = seq.open.local(input.file,"r",0)
        if(inputfile<0) then
So what you could try is this:
Code:
	logo_fp = seq.open.local(DEFAULT,"r",0)
	if logo_fp < 0 then
		ret = server2client(HEADER, DEFAULT, 0)
if logo_fp is <0 you know the logo does not exist and then download it. Or if you want just always download the logo so you know it is the correct and current logo. In that case just remove the if statement for file.stat or seq.open.local - which ever you use. Just make it do this every time it runs. Notice I just commented out the checks.
Code:
|	logo_fp = seq.open.local(DEFAULT,"r",0))
|	if logo_fp < 0 then
		ret = server2client(HEADER, DEFAULT, 0)
		if  ret < 0 then
			message("Logo not available")
		endif
|	endif	
__________________
Mark

GO Cards!
My latest mantra - make sure you have latest stpapi patches and the latest session object. If on LN then please explore the option of using DAL2 functionality.

Shared Solutions for Baan systems provided free by Baan Board.
Play the Google game and help Baanboard get better rankings. Do your part. Click here to find how.
Reply With Quote
  #32  
Old 6th April 2013, 16:24
bhushanchanda's Avatar
bhushanchanda bhushanchanda is online now
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,286
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
Everthing works well now!

Hi Mark,

Attaching a new file with everything working fine now. I observed that, the extension of the image file was causing a problem as well as the following code lines:-


Code:
	logo_fp = seq.open.local(DEFAULT,"r",0))
	if logo_fp < 0 then
		ret = server2client(HEADER, DEFAULT, 0)
		if  ret < 0 then
			message("Logo not available")
		endif
	endif
I changed it to as you suggested. I commented the lines as you said.

Code:
|	logo_fp = seq.open.local(DEFAULT,"r",0))
|	if logo_fp < 0 then
		ret = server2client(HEADER, DEFAULT, 0)
		if  ret < 0 then
			message("Logo not available")
		endif
|	endif
And now it worked. The return value for logo_fp was causing the problem.
Attached Files
File Type: bc script.bc (4.6 KB, 13 views)
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
  #33  
Old 7th April 2013, 03:06
xlcwas0 xlcwas0 is offline
Junior Member
 
Join Date: May 2011
Posts: 7
xlcwas0 is on a distinguished road
Baan: FP3 - DB: oracle - OS: windows7
Quote:
Originally Posted by mark_h View Post
See the all the posts on how to setup device and everything. The question is - is the script compiling for you? Or are you getting this when trying to run a report to html.
hi, the script compiling no any errors, it's only display with run a report to html. [last function :rpos]
thanks.
Reply With Quote
  #34  
Old 7th April 2013, 07:52
bhushanchanda's Avatar
bhushanchanda bhushanchanda is online now
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,286
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
Hi xlcwas0,

Can you specify what the problem is? Also refer to the snapshots posted in the thread.
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
  #35  
Old 7th April 2013, 09:21
xlcwas0 xlcwas0 is offline
Junior Member
 
Join Date: May 2011
Posts: 7
xlcwas0 is on a distinguished road
Baan: FP3 - DB: oracle - OS: windows7
Quote:
Originally Posted by bhushanchanda View Post
Hi xlcwas0,

Can you specify what the problem is? Also refer to the snapshots posted in the thread.
hi, bhushanchanda

fyi.
Attached Images
File Type: jpg 2013-04-07_151801.jpg (113.8 KB, 12 views)
Reply With Quote
Sponsored Links
  #36  
Old 7th April 2013, 10:53
bhushanchanda's Avatar
bhushanchanda bhushanchanda is online now
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,286
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
Same problem!!

Well, I will suggest you to go through the posts in the thread.
Check if the temp files are created on the server. Also, check if your local path has proper write permissions.

I have already attached the snapshots. Attaching them again.

The problem I think is in your device setup as the src file is blank.

Please do the device settings as mentioned and try again.

Also, post your device snapshots to verify if everything is correct.
Attached Images
File Type: jpg Device.jpg (76.3 KB, 9 views)
File Type: jpg 2.jpg (61.5 KB, 9 views)
Attached Files
File Type: bc script.bc (4.6 KB, 11 views)
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
  #37  
Old 8th April 2013, 05:29
xlcwas0 xlcwas0 is offline
Junior Member
 
Join Date: May 2011
Posts: 7
xlcwas0 is on a distinguished road
Baan: FP3 - DB: oracle - OS: windows7
Quote:
Originally Posted by bhushanchanda View Post
Same problem!!

Well, I will suggest you to go through the posts in the thread.
Check if the temp files are created on the server. Also, check if your local path has proper write permissions.

I have already attached the snapshots. Attaching them again.

The problem I think is in your device setup as the src file is blank.

Please do the device settings as mentioned and try again.

Also, post your device snapshots to verify if everything is correct.
hi, bhushanchanda and mark h

thank you very much,it's working!!
Reply With Quote
  #38  
Old 8th April 2013, 05:59
bhushanchanda's Avatar
bhushanchanda bhushanchanda is online now
Guru
 
Join Date: Sep 2012
Location: India
Posts: 2,286
bhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura aboutbhushanchanda has a spectacular aura about
Baan: LN FP 1-9, 10.4, a little bit of Baan IV - DB: SQL Server 2008, Oracle - OS: Windows Server 2008 R2, Unix
Thumbs up

Well done!! :)
__________________
Regards,

Bhushan

Unless you try to do something beyond what you have already mastered, you will never grow!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are Off
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DEVICE screen not picking up Preferred Device wmickey Tools Administration & Installation 6 21st September 2007 19:39
How to print Postcript in landscape orientation heliopaixao Tools Administration & Installation 8 28th July 2006 13:39
Maintain Device & Queue Inf please rmarles Tools Administration & Installation 0 9th January 2004 20:46
Device related problem !!!! learner Tools Administration & Installation 7 25th January 2003 02:07
Defining Device Type Within Program. muheeb Tools Development 1 20th March 2002 14:03


All times are GMT +2. The time now is 06:22.


©2001-2017 - Baanboard.com - Baanforums.com