View Single Post
  #5  
Old 10th July 2002, 21:27
Francesco's Avatar
Francesco Francesco is offline
Guru
 
Join Date: Aug 2001
Location: Antwerp, BE
Posts: 727
Francesco is on a distinguished road
Baan: 5b - DB: Oracle - OS: Solaris
Those are all good suggestions Victor.

I actually created a DBLOG file, when I was able to reproduce the error some time ago. The log was terminated as abruptly as the connection. I was unable to extract any valuable info from it.
Here are the last 10 lines...it simply stops after this.

Bind :1 : string : '040'
Bind :2 : string : ' 51-'
------ QPS Output Row -------
Bind 1 : blck : char : <2>
Bind 2 : dsca : string : 'FRESNO PID MFG '
Bind 3 : ffno : long : <452>
Bind 4 : ffst : char : <0>
Bind 5 : nrgr : string : '040'
Bind 6 : seri : string : ' 51-'
Bind 7 : lngt : char : <3>


LAN (WAN) and performance are high on my suspect list. I did ask this one user to try it from a different machine however, and he got the same result. What's worse, he logged on as a different user and got the same result. That user himself could work just fine from ahy machine.
Now if it was just that one user, I would probably see what's in his desk drawers before I see what's in his PC, but it happens to a handful of users across the country.
Same users, same error, comes and goes. :confused:

I did check for network collissions, but everything looks clean.
example:
Name Mtu Net/Dest Address Ipkts Ierrs Opkts Oerrs Collis Queue
lo0 8232 loopback localhost 446064368 0 446064368 0 0 0
qfe0 1500 otherserver otherserver 44215519 0 33175362 0 0 0
qfe5 1500 myserver myserver 362317672 7 396039668 0 0 0


I had a team of hotshot IBM consultants check out my kernel settings last year, and they were able to solve most (if not all) of the performance problems we were suffering then.
It is probably time to do evaluate these settings again (more sites, more users, more everything), but somehow I don't think that this would be the core problem.
Then again, if I knew what was at the core of this problem I would have bloody well fixed it by now, right? ;)
So here you go (sar -v 5 5):

SunOS uscobrmfa-ue-25 5.6 Generic_105181-26 sun4u 07/10/02

13:21:55 proc-sz ov inod-sz ov file-sz ov lock-sz
13:22:00 1682/16394 0 31168/69992 0 22043/22043 0 0/0
13:22:05 1684/16394 0 31168/69992 0 22056/22056 0 0/0
13:22:10 1681/16394 0 31168/69992 0 22034/22034 0 0/0
13:22:15 1678/16394 0 31168/69992 0 22016/22016 0 0/0
13:22:20 1670/16394 0 31168/69992 0 21954/21954 0 0/0


etc/system :

set scsi_options=0x7f8
set sd:sd_io_time=0x78
set sd:sd_max_throttle=20
set maxphys=2097152

set tune_t_gpgslo=250
set tune_t_minarmem=100
set tune_t_minasmem=250
set rstchown=0

* Message Queue Parameters
set msgsys:msginfo_msgmap=712
set msgsys:msginfo_msgmax=8192
set msgsys:msginfo_msgmnb=65536
set msgsys:msginfo_msgmni=1024
set msgsys:msginfo_msgseg=8192
set msgsys:msginfo_msgssz=16
set msgsys:msginfo_msgtql=1802

* Semaphore Parameters
set semsys:seminfo_semmap=3202
set semsys:seminfo_semmni=3200
set semsys:seminfo_semmns=3200
set semsys:seminfo_semmnu=3200
set semsys:seminfo_semmsl=3200
set semsys:seminfo_semopm=32
set semsys:seminfo_semume=100

* Shared Memory Parameters
set shmsys:shminfo_shmmax=0xffffffff
set shmsys:shminfo_shmmni=320
set shmsys:shminfo_shmseg=200

set priority_paging=1

set pln:pln_enable_detach_suspend=1
set soc:soc_enable_detach_suspend=1
set socal:socal_enable_suspend=1
set tcp:tcp_conn_hash_size=8192
set dosynctodr=0

* vxfs_START -- do not remove the following lines:
set lwp_default_stksize=0x4000
set rpcmod:svc_run_stksize=0x4000
* vxfs_END

* vxvm_START (do not remove)
forceload: drv/atf
forceload: drv/pln
forceload: drv/ses
forceload: drv/vxdmp
forceload: drv/vxio
forceload: drv/vxspec
forceload: drv/sd
forceload: drv/QLGC,isp
forceload: drv/sbus
forceload: drv/ssd
forceload: drv/sf
forceload: drv/soc
forceload: drv/socal
rootdev:/pseudo/vxio@0:0
set vxio:vol_rootdev_is_volume=1
* vxvm_END (do not remove)

forceload: drv/st
forceload: drv/sg
forceload: drv/fcaw

set rlim_fd_cur=2048
set rlim_fd_max=8192
set npty=350

set ecache_calls_a_sec=1
set ecache_scan_rate=1
*set ecache_is_mirrored=1

* force all qfe interfaces to 100MB Full Duplex No Autoneg
set qfe:qfe_adv_autoneg_cap=0
set qfe:qfe_adv_100T4_cap=0
set qfe:qfe_adv_100fdx_cap=1
set qfe:qfe_adv_100hdx_cap=0
set qfe:qfe_adv_10fdx_cap=0
set qfe:qfe_adv_10hdx_cap=0


See anything disturbing?
__________________
Cheers,

Francesco
..............................................................

Admiral Business Solutions | My World | Baan Board | IT Happens!

"If everyone is thinking alike, then somebody isn't thinking" -- George Patton
"It's easy to cry 'bug' when the truth is that you've got a complex system and sometimes it takes a while to get all the components to co-exist peacefully." -- Doug Vargas
Reply With Quote