View Single Post
  #6  
Old 3rd April 2017, 15:37
VishalMistry's Avatar
VishalMistry VishalMistry is offline
Guru
 
Join Date: Dec 2004
Location: India, Gujarat
Posts: 590
VishalMistry has a little shameless behaviour in the past
Baan: Baan IV, ERPLn - DB: SQL Server 2000 / 2008 - OS: Windows Server 2003 / 2008
Red face Tried but no luck

Quote:
Originally Posted by mark_h View Post
Actually see if this works:
Code:
	stpapi.handle.subproc( "tdpur4421m000", "tdpur4820s000", "add")	
        stpapi.put.field( "tdpur4421m000", "selection", str$(tcyesno.yes))
	stpapi.continue.process("tdpur4421m000",err)
This should get 8420s000 started - it did on my system. I am thinking you want all you setups for tdpur4421m000 done before that continue. Something like this:
Code:
	i.spooler = spool.open("", "", 1)
	stpapi.set.report( "tdpur4421m000", "rtdpur442101100", spool.device, error.msg )
	stpapi.handle.subproc( "tdpur4421m000", "tdpur4820s000", "add")	
        stpapi.put.field( "tdpur4421m000", "selection", str$(tcyesno.yes))
	stpapi.continue.process("tdpur4421m000",err)
	stpapi.put.field( "tdpur4820s000", "orno.select", str$(load.long(receipts.array(pos.orno,1))), 1)
	stpapi.put.field( "tdpur4820s000", "orno.select", str$(load.long(receipts.array(pos.orno,2))), 2)
	stpapi.continue.process( "tdpur4820s000" , error.msg)
I am not really sure what will happen after the continue on 4820s000, but I think tdpur4421m000 might start processing. I could be wrong, not really sure.
I tried your given code snippet but no luck. The session still hangs. The other way I tried is also attached as a script. Still I am facing session hang.

Vishal
Attached Files
File Type: cln print.storage.list.cln (1.2 KB, 5 views)
Reply With Quote