View Single Post
  #1  
Old 5th October 2017, 14:50
shijil shijil is offline
Newbie
 
Join Date: Sep 2017
Posts: 2
shijil is on a distinguished road
Baan: FP7, 10.4,10.5 - DB: SQL - OS: Windows
Exclamation DataArea fields are blank/nothing when accessing via .NET application
Baan: ERP LN 6.1 FP7 (Infor ERP 10.1)
C/S: Both

I am developing a BDE solution to push/pull data from and to a third party application. So that I can convert the same to web service which can be consumed by the third party application. I tried to import table from data dictionary in Business Studio,and then generated. I am able to consume standard methods like "Show" post implementing the solution via web service in .NET program. However Response object fields are not displaying values.
Also attached the trace log

Here is the sample program I use to retrieve values

Code:
Function ValidateProductionOrder(pOrder As String) As Boolean

            Dim sRequest As New ShowRequest

            sRequest.ShowRequest1 = New ShowRequestType()
            sRequest.ShowRequest1.DataArea = New ShowRequestTypeDataArea()
            sRequest.ShowRequest1.DataArea.EstimatedAndActualMaterialCosts = New ShowRequestTypeDataAreaEstimatedAndActualMaterialCosts()
            sRequest.ShowRequest1.DataArea.EstimatedAndActualMaterialCosts.position = 10
            sRequest.ShowRequest1.DataArea.EstimatedAndActualMaterialCosts.productionOrder = pOrder.ToString()


            Dim sResponse As New ShowResponse


            Dim o As New EstimatedAndActualMaterialCostsClient

            Try

                sResponse = o.ServiceReference3_EstimatedAndActualMaterialCosts_Show(sRequest)

            Catch ex As Exception
                Console.WriteLine(ex.Message)
            End Try

            If sResponse.ShowResponse1.DataArea.ProductionOrders.productionOrder = pOrder.ToString() Then
                Return True
            Else
            Return False
            End If

        End Function
Reply With Quote